PDA

View Full Version : What is the diference between Singletexture, multitexture, GLSL



daren
26-Nov-11, 07:38
What is the difference between the three?

cig
26-Nov-11, 09:20
Hi Daren.

You can see the effect of the different types in the 3D VIEW, while in textured mode, (on the 3D VIEW task bar - wire solid/shaded / textured).


You can look for information in BlenderWiki, just google search.

I'm finding it hard to locate any updated information on this topic for 2.5+ though. - any other members input welcome -.

Basically these different options are more relevant, when using the game engine, though you can use them to create quick test animation renders of the 3D VIEW, (button on the task bar attached to the 3D VIEW).

The last one GLSL, uses the "OpenGL" rendering method, and allows for shadows and better shading of the scene. It also uses the graphics cards built in functions, (and drivers), to calculate the shading and texturing, (accelerated; though I am not sure how much of this has been implemented within Blender at present. It will make more demands on your system, if you add a large number of shadowmap lights, so it is best to limit the number of shadow casting light sources down.




Are you using 2.4+? Those terms "single etc" are more in line with those versions.



Regards.


Cig.

daren
26-Nov-11, 09:36
Thanks -- the reason I asked is I can't go into openGL textured mode for my current scene -- I thing it uses too much memory for my graphics card - so I was wondering if I one of the othe settiings would do basically the same thing but CPU based.

UncleGummy
26-Nov-11, 16:54
In 2.6a, the Singletexture/Multitexture/GLSL button is in the N panel, under the Display tab thingee.
I'll be sure to check it out the next time I play around in the Game Engine!

bat3a
27-Nov-11, 21:18
some talk regarding this matter happening in the mailing list, they think it needs a refactor for clarifying the options, which i do agree with :)

cig
28-Nov-11, 07:24
Thanks -- the reason I asked is I can't go into openGL textured mode for my current scene -- I thing it uses too much memory for my graphics card - so I was wondering if I one of the othe settiings would do basically the same thing but CPU based.

I gather you already know how to go into GLSL mode etc and you're viewing your scene in TEXTURED view.
You also have a OpenGL compliant card, because you typed "for my CURRENT scene", and have successfully used GLSL before.

What graphics card, and how much Vram?

Don't forget to upgrade your graphic card drivers and your shader pack, (some card manufacturers do NOT include new shader updates along with the card drivers. You have to download them separately).

To check if it is a file data size issue. Make a copy of the .Blend file somewhere away from your genuine work. Try using GLSL.
If it does not work, start deleting objects from the scene, and keep trying GLSL. If it starts working, you have found your threshold.

You can also set the -d option at the end of your Blender.exe line, in your shortcut icon, (Windows: Mac not sure yet). This will leave the debug console available, after your blend session, with any failure reports, (does not show reports for everything).


Don't forget that when you view one of your texture images in your directory listings, you are most probably viewing the COMPRESSED to disk value, not the UNCOMPRESSED while in memory value. If one of your images for mapping is large when compressed it will be MASSIVE, when unpacked.

Try and keep your textures to the minimum. Only make images as large as the VIEWING size on screen, (if you are working in 1024x768, then an image in the background that only uses 1 quarter of the screen area, only needs a texture 1 quarter of 1024x768, to be acceptable for high quality viewing, (as long as it is not wrapped around a cylinder etc, but then you can texture only the viewed area and leave the back faces blank).

Cut out all back faces, you do not need. If a pillar has a set of faces on the bottom of the base, and those faces are hidden by the floor. Delete those faces. Make sure you are not using a duplicate object before deleting faces /vertices though, otherwise you may end up with a duplicate object with holes facing the camera.




Would someone please confirm for me, as I do not have Blender at my fingertips, when on-line. There is a SYSTEM report in the new Blender 2.5+ that gives an indication of resources Blender is using, including memory?



Regards.


Cig.

Out if time. Error checking to follow.

daren
28-Nov-11, 08:18
Hey Cig -- thanks for the elaborate reply --
I have a GTX 9600 (512 MB)

I use open GL renders extensively as I set up my scenes -- currently I am doing a scene that will be approx 10 000 frames long and have 150 shots or so -- I use open GL to puttogether the scene in the VSE before I do final rendering and it lets me get started on SFX and stuff --

point is - yes I have used openGL to render textured previews before.

I really can't optimize the scene that much, as I have shots from various and moving camera angles and such -

Ican tell you, the current scene (in solid view, not textured) takes approx 700 MB memory.

This isn't a fatal error - I can render solid view GL renders - it just doesn't give the nuances of texture that is kind of nice to have.

cig
28-Nov-11, 09:31
Sorry daren, I'm on a time limit at the local library, (2, 1 hour sessions per day).
Moving out of my 22 year home on Friday so everything is HECTIC. Cannot wait to get my own internet connection, as trying to troubleshoot without the different blender versions in front of me, inevitably ends up with some errors in my posts, and later needed corrections.

Nvidea based GTX 9600(512 MB).

Is the 700MB total INCLUDING video memory? I would think that the 700 MB is just the machine ram used, not the "on the fly" loading of textures into Vram.

The problem is that the graphics card has to load the textures LIVE, and unless the card is capable of "borrowing" some machine RAM, big textures will cause problems.

I gather you have not turned off the mip mapping for the textures. Athough mip mapping, only saves reduced copies of an already available "larger" texture, and can make textures look second rate; it does cut down on the poor gpu's work load and memory requirements.

Check your texture image MEMORY sizes, NOT file sizes, in a graphics program such as GIMP, this will show you the TRUE cost of your images, while working in Blender.It's easy to get carried away, thinking that bigger is better. You may shock yourself seeing the "TRUE" size of some of your textures.


Rather than keep posting "possibles". I'll scan for some guidelines that show the max working boundaries for your card, and your available Vram within the GLSL environment.
I'll place them in this post for you.

If someone else solves your problem first... Great!

Regards.

Cig.

daren
28-Nov-11, 15:18
700 MB without VRAM -- and yes -- the textures are very large- some 4k ones.

I had never heard of the MIP mapping option before (I had noticed it, but never investigated its function) -- I will check that out.

Don't spend too much mental energy on it - I can certainly get by without it -

House of 22 years? ! What caused the move?

cig
29-Nov-11, 09:47
700 MB without VRAM -- and yes -- the textures are very large- some 4k ones.

I had never heard of the MIP mapping option before (I had noticed it, but never investigated its function) -- I will check that out.

Don't spend too much mental energy on it - I can certainly get by without it -

House of 22 years? ! What caused the move?


OpenGL is really meant for low/medium poly, LOD texturing anyway.

I am not sure if this will be relevant for you, but it is worth a try. Look in the RENDER tab for performance, (while in BLENDER GAME MODE), and find the check box for DISPLAY LISTS. If you turn it off, it gives the geometry work to the CPU rather than the GPU.
I am not sure if this will be relevant for OpenGL rendering to file, (rather than the game engine).

Don't forget to monitor your CPU/GPU temperatures while working.


As to me leaving. I left in the end for health reasons, and it was time to move on, (living in one room for 22 years is not good for you, I should know).


If I come across any more data, I'll let you know.


Hope your work goes well.



Cig.


Oh. By the way. If you are not using bump mapping with OpenGL, you could also turn off the "extended textures/shaders option, within the OpenGL section".