PDA

View Full Version : Locking a viewport (avoid rotation)



Remenic
29-Nov-04, 13:11
I'm new to blender 3D and not skilled at 3D modelling at all. I have some some other programs before, but I want to use Blender 3D from now on (being an opensource freak and stuff).

I'm finding my way around Blender and I'm liking everything so far, but I have the habit of rotating my 'front' 'side' and 'top' viewports (I have 4 viewports in total). Is there a way to lock the viewport so it will only move but not rotate anymore?

I have checked google and ran some search queries on this forum, but nothing came up for me, so I'm hoping someone knows.

SoftWork
29-Nov-04, 13:28
No, as far as I know this is not possible. Fortunaly you can allign the views easily with numpad-7, 1 and 3.

Remenic
29-Nov-04, 14:46
No, as far as I know this is not possible. Fortunaly you can allign the views easily with numpad-7, 1 and 3.Yeah that works great...on a fullsize keyboard. I'm one those few unfortunates that works on a laptop, and numpad-# isn't as easily accessible then :)

Is there a place where I can submit feature requests? This 'feature' should be very easy to implement.

nico
29-Nov-04, 16:58
Pull down the top header and select 'Emulate numpad' under 'View & Controls'. Voila. :)

I am so used to it that I even select this on desktop computers.

Remenic
29-Nov-04, 17:40
Pull down the top header and select 'Emulate numpad' under 'View & Controls'. Voila. :)

I am so used to it that I even select this on desktop computers.That was a magical tip! I have changed a lot of things that make Blender 3D that much easier to use for me :)

Thank you so much!

TakingHits
29-Nov-04, 17:50
If you are using 2.3+ (i think), in the 3D view, goto View ==> select front, side, top, etc

Remenic
29-Nov-04, 18:15
If you are using 2.3+ (i think), in the 3D view, goto View ==> select front, side, top, etcYeah that switches the view, but I'm still able to rotate it. However, setting the default middle-mouse button to pan instead of rotate limits the chance to accidently rotate the view.

fobsta
30-Nov-04, 14:53
Ha this is exactly the same problem I had when I first came to blender about six months ago.

Put in a feature request