Results 1 to 6 of 6
  1. #1

    Troubles iwth UV unwrapping

    This seems like a bug to me, but perhaps I just don't understand UV unwrapping enough. I am using Blender 2.59 from blender.org.

    I started with the default cube, scaled it, Z axis by 0.125, then I cut out a hole in the middle, essentially turning it into a rectangular torus. I marked some seams, UV unwrapped, and did not get anything unexpected. Here is a screen capture.

    Click image for larger version. 

Name:	uvprob01.jpg 
Views:	55 
Size:	67.7 KB 
ID:	157443

    It was what I did next that threw me. While in edit mode, with all vertices selected, I scaled it, Y axis, by 4. Then when I UV unwrapped, it came out distorted. Here is a screen capture.

    Click image for larger version. 

Name:	uvprob02.jpg 
Views:	72 
Size:	75.1 KB 
ID:	157444



  2. #2
    When you unwrap make sure the axes are all set to 1, otherwise you'll get a distorted unwrap. Reset them with Ctrl+A / Scale. Also for non-organic objects you'll generally get a better unwrap with the unwrap method set to Conformal instead of the default Angle Based.



  3. #3
    The scale was reset using Ctrl+A / Scale after the first scaling operation, it is just that I forgot to mention it. For the second scaling operation, I did it in Edit mode which does not affect scale, but after reading your reply, I went back into the file and checked it to be sure. The scale is set to 1.

    Regarding Conformal based unwrapping, I could not find where to set that. When I did the unwrap in both cases, I typed the "u" key, then chose "Unwrap", which is tied to the "u" key as well. So, what I did was "u" + "r" to reset, then "u" + "u" to unwrap with all vertices selected.

    John



  4. #4
    Talking of scale reminded me of something that I experimented with earlier. I went back to the original small object. In Object Mode, I scaled it on the y axis by 4 (s y 4). I did not adjust scale for this next step. I went into Edit Mode, selected all vertices, (u r) to reset the previous unwrapping, (u u) to unwrap anew, and it came out right.

    Then back to Object Mode, (Ctrl+A / Scale), back into Edit Mode, all vertices were still selected, then (u r) to reset the previous unwrapping, (u u) to unwrap anew, and it came out distorted, so applying scale actually makes it worse, at least in this case.

    John



  5. #5
    Regarding Conformal based unwrapping, I could not find where to set that.
    Press U to unwrap and you'll see the option in the bottom of the toolshelf (keyboard T or by pressing F6)



  6. #6
    That fixed it. I usually keep the T and N panels up, but because I was trying to get nice screen captures, I got rid of the panels to unclutter the images. No wonder I didn't see where to set conformal unwrapping. Thank you for your help.

    John



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •