Results 1 to 9 of 9
  1. #1
    Member konrad_ha's Avatar
    Join Date
    Feb 2004
    Location
    Munich | Germany
    Posts
    204

    Cycles: huge white dots problem, scene included

    Hi everyone,

    Cycles brought me back to Blender again. The first impressions are incredibly positive, but now I'v hit the first roadblock:

    In the attached image you will see horrible, horrible fireflies (or white dots). It's probably due to the liberal use of a glass material and indirect lighting, but these are just necessities for this scene.

    Click image for larger version. 

Name:	cycles_white_dots_hell.jpg 
Views:	1142 
Size:	574.9 KB 
ID:	161307

    I played with pretty much any setting in the integrator and none had any positive effect on the dots.

    I attached the scene so you can try to render it without artifacts.

    droplet_011.blend

    Blender Version: 2.60.5 r42025 with Cuda support.

    Any help is appreciated.
    Last edited by konrad_ha; 21-Nov-11 at 07:24.
    "Stills are nice, animation is where the big boys are." - me

    Vimeo: http://vimeo.com/konradhaenel/videos
    Business: http://marcrea.de



  2. #2
    Member konrad_ha's Avatar
    Join Date
    Feb 2004
    Location
    Munich | Germany
    Posts
    204

    Thumbs up

    THE SOLUTION:

    Some browsing through this forum got me to this thread, describing the source of the fireflies: http://blenderartists.org/forum/show...oise-in-Cycles
    They tend to appear when direct light is bounced ONCE off an object and then into the camera, causing a near reflection of the super-bright lightsource.
    I adjusted my lightsources accordingly so that direct reflections and refractions would be highly unlikely. I also made my lightsource-objects invisible as lined out in this post: http://blenderartists.org/forum/show...mission-Source

    Now I can render the scene without fireflies and with all the lighting I want. See the attached file for the solution.

    Click image for larger version. 

Name:	cycles_perfection.jpg 
Views:	840 
Size:	269.9 KB 
ID:	161313

    Also: Cycles is amazing!
    Attached Files Attached Files
    "Stills are nice, animation is where the big boys are." - me

    Vimeo: http://vimeo.com/konradhaenel/videos
    Business: http://marcrea.de



  3. #3
    Member ampace's Avatar
    Join Date
    Nov 2009
    Location
    Denver Colorado
    Posts
    411
    Great job, and great tip! Thanks!
    My Blog - Game reviews; thoughts on game design, game art and other things. I also give some reviews on the Full Sail Game Design program.

    Full Sail University Game Design - Class of 2012



  4. #4
    Thanks for the tip, may have the same problem and will try to fix it!

    B.



  5. #5
    Member JulianLorenz's Avatar
    Join Date
    Nov 2011
    Location
    Siegen, Germany
    Posts
    19
    There is also another way to fix the problem with the white dots: Just go to renderoptions>integrator and check "No Caustics". In addition there is an option to filter the reflections underneath, but i found it is unnecessary to deal with it....
    Have a watch at my blog: http://julianlorenz.wordpress.com/



  6. #6
    Member
    Join Date
    Sep 2012
    Location
    Paris
    Posts
    15

    Another solution to white dots / speckles

    Originally Posted by JulianLorenz View Post
    There is also another way to fix the problem with the white dots: Just go to renderoptions>integrator and check "No Caustics". In addition there is an option to filter the reflections underneath, but i found it is unnecessary to deal with it....
    Hello, I found another one, which works very well for me (while "no caustics" did not): set Clamp to something more than 0, in the same "Integrator" area. 1, 2, 5, 10, ... you can test it out. 0 means no limit, and this seems to result in speckles.



  7. #7
    Member abhaya's Avatar
    Join Date
    Aug 2012
    Location
    Gdynia
    Posts
    30
    I confirm ~patb solution worked out for me.



  8. #8
    Member liwid's Avatar
    Join Date
    Apr 2013
    Location
    Sweden
    Posts
    4

    How to keep good lighting when increasing clamp value

    I just made an eyeball somewhat according to a tutorial,
    but when rendering I got a whooole lot of fireflies on the glass material.
    I heard about setting the Clamp value to 0.98, but that
    completely killed the strength and contrast in the lighting?
    Any suggestions how I get the same light effect with the new clamp value?

    This is the rendered picture with 1000 samples 100% resolution
    http://imgur.com/3wsQdlT
    and this is how dull it got with clamp value of 1
    http://imgur.com/yaTg9X4

    What the fuck

    Im completely new to 3D programs so Im sorry if the question is retarded haha..
    All help appreciated,
    Lisa



  9. #9
    Member liwid's Avatar
    Join Date
    Apr 2013
    Location
    Sweden
    Posts
    4
    Hi, when increasing the clamp value to 0.98 which I heard was good,
    the strength and contrast in my lighting completely died!

    without clamp:
    http://imgur.com/tenfLin,6HMtVwe#1

    clamp value of 1
    http://imgur.com/tenfLin,6HMtVwe#0

    Im sort of new to rendering so I might be retarded, but:
    how do I compensate in other settings to keep the contrast while having a clamp value?

    All help appreciated
    Lisa



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •