Results 1 to 7 of 7
  1. #1

    Editing in pose mode

    My apologies for the simplest of questions, but I can't recall how to edit the mesh after applying the armature modifier. In other words, the armature is moved, the mesh of course follows the movement, but then when I hit edit on the mesh, it returns to the at-rest position. I don't want it to.
    Thanks



  2. #2
    Member
    Join Date
    Oct 2006
    Location
    Ansbach, Germany
    Posts
    260
    I'm not quite sure if I understood correctly: After applying the modifier, the mesh has no relation to the armature anymore, so, going into edit mode shouldn't do this because there is just no rest position.

    If "applying" means that you have added the modifier, then it's a bit confusing, because applying usually means hitting the "apply" button in the modifier panel. If you have added the modifier, you can click on the 3rd icon to the right of the modifier name. Another icon ("apply during editting") appears which you can activate also.



  3. #3
    Member Kaluura's Avatar
    Join Date
    Jun 2012
    Location
    Oort Cloud
    Posts
    1,172
    I kinda guessed that you want to go into Pose mode instead of Edit mode... That's [ALT TAB]. There you can move the armature and the mesh follows.

    Use [ALT TAB] again to go back to Object mode.

    You can also use the selector in the header of the 3D view, the one which says "Object Mode" or "Edit Mode".
    -- Creative thinking?



  4. #4
    Member
    Join Date
    Oct 2011
    Location
    Firenze
    Posts
    2,438
    Maybe you wrongly used the word 'apply' while you means 'added an armature modifier', if it's so, then you have to activate the option 'use modifier while in the Edit mode', it is the icon with a cube and four vertices, on the right of the modifier name.

    paolo



  5. #5

    Maybe this will help

    Snake Test.zip What happens is when I hit edit on the mesh, the snake, it closes it's mouth so I can't work on it. Like I said, easy problem, just can't figure it out.
    Thanks again.



  6. #6
    Member Kaluura's Avatar
    Join Date
    Jun 2012
    Location
    Oort Cloud
    Posts
    1,172
    Now, I understand the problem...

    Name:  snap12.png
Views: 76
Size:  33.8 KB

    Activate (1) "Use modifier while in Edit mode" on the Armature modifier. Then (2) "Apply modifier to editing cage" will appear. Activate it too. This way, you can edit your mesh and it will stay posed.

    There is however a slight bug which makes the cursor stick to the non-posed position of the selection. I guess that's why I don't use much these options.

    When you want to edit unreachable parts of a mesh, just hide what's in your way. Select and type [H] to hide. ([ALT H] to unhide.) Or use the wire mode: [Z]. Or else, deactivate the "Limit selection to visible" option.

    Name:  snap22.png
Views: 78
Size:  6.5 KB
    -- Creative thinking?



  7. #7
    Perfect! Thank You, problem solved!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •