Results 1 to 10 of 10

Thread: "Play" button in sound block does not play sound. Unable to scrub audio

  1. #1
    Member bgryderclock's Avatar
    Join Date
    Dec 2006
    Location
    Charlotte NC USA
    Posts
    13

    "Play" button in sound block does not play sound. Unable to scrub audio

    I am have difficulty previewing audio in blender.

    The "Play" button in the sound block buttons does not play sound. I am also unable to scrub audio while grabbing moving the the frame slider as specified in these tutorials:

    http://wiki.blender.org/index.php/Ma...udio_Sequences
    http://wiki.blender.org/index.php/BS...d_and_lip_sync

    FFmpeg is selected. Multiplex audio, the little speaker, Sync and scrub is Enabled. (please see attached screen shots)

    I am working in Ubuntu Linux with Gnome. If I export a mpg test file please audio works fine. i am just unable to scrub/preview it to sync it to animation.

    Any suggestions or links would be greatly appreciated!



    -> EFF.org <- Support the troops!



  2. #2
    Hello
    Linux, Blender and sound it's a bit special?!
    Have you tried sound in the Game engine? Probably it's working?
    Anyway start Blender from the console like this and tr again:
    blender -g noaudio
    Bye



  3. #3
    Member bgryderclock's Avatar
    Join Date
    Dec 2006
    Location
    Charlotte NC USA
    Posts
    13
    Originally Posted by OTO View Post
    Hello
    Linux, Blender and sound it's a bit special?!
    Have you tried sound in the Game engine? Probably it's working?
    Anyway start Blender from the console like this and tr again:
    blender -g noaudio
    Bye
    Thanks for the quick reply.

    I tried "blender -g noaudio" No audio played but there were no error messages showed in the terminal window.

    edit:Wait! terminal showed this when i quit blender

    [email protected]:~$ blender -g noaudio
    guessing 'blender-bin' == '/usr/bin/blender-bin'
    Compiled with Python version 2.5.1.
    Checking for installed Python... got it!
    Couldn't open audio: No available audio device
    Saving: /tmp/0001_0030.wav totlen 211724
    Couldn't open audio: No available audio device
    Couldn't open audio: No available audio device
    Saved session recovery to /home/user/.blender/quit.blend
    How do I test sound in the Game engine?

    What is the proper setting for Audio mixing buffer under "System and OpenGL"?
    Last edited by bgryderclock; 22-Jan-08 at 22:36. Reason: more info appeared
    -> EFF.org <- Support the troops!



  4. #4
    Member bgryderclock's Avatar
    Join Date
    Dec 2006
    Location
    Charlotte NC USA
    Posts
    13

    export SDL_AUDIODRIVER=alsa && blender -g noaudio worked

    I got it working in feisty Ubuntu Linux with this command in the terminal:

    export SDL_AUDIODRIVER=alsa && blender -g noaudio

    Yea!
    -> EFF.org <- Support the troops!



  5. #5

    how about rendering

    I had similar case here, how about rendering how I can get sound file attatched to output animation?



  6. #6
    Member garuhhh's Avatar
    Join Date
    Jul 2006
    Location
    Pampanga, Philippines
    Posts
    696
    export SDL_AUDIODRIVER=alsa && blender -g noaudio
    i've gotta try this... had the same problem with xubuntu 7.10, scrubbing didn't work, but it did well in winxp.

    what does the command supposed to do? thanks!



  7. #7
    Member bgryderclock's Avatar
    Join Date
    Dec 2006
    Location
    Charlotte NC USA
    Posts
    13
    Originally Posted by anv View Post
    I had similar case here, how about rendering how I can get sound file attatched to output animation?
    After i preview the animation i select the the scene button and the the sound button and enable scrub, sync and mixdown.

    then in i click the render button, and on the format tab i select "ffmpeg", on the video tab i select "mpeg-2", and in the Audio tab i enable "Multiple Audio", "mp2" and Bitrate 128.

    Then in the Anim tab i click "Do sequence", "Do composite" and then the big Anim button.

    http://www.fileden.com/files/2007/7/.../0001_0120.dvd<- this opens in mplayer or totem





    http://www.fileden.com/files/2007/7/...1/helpanv3.png

    this what worked for me, I may have included unneed steps.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	helpanv3.png 
Views:	82 
Size:	30.6 KB 
ID:	34031  

    Last edited by bgryderclock; 08-Feb-08 at 13:04.
    -> EFF.org <- Support the troops!



  8. #8
    Member bgryderclock's Avatar
    Join Date
    Dec 2006
    Location
    Charlotte NC USA
    Posts
    13
    Originally Posted by garuhhh View Post
    i've gotta try this... had the same problem with xubuntu 7.10, scrubbing didn't work, but it did well in winxp.

    what does the command supposed to do? thanks!
    i got it from a Ubuntu bug report, it sets some blender variable to use the ubuntu alsa drivers and then starts blender in no game audio mode. the "&&" separates the two commands like a hitting the enter key.
    Last edited by bgryderclock; 08-Feb-08 at 15:22. Reason: More typos than information
    -> EFF.org <- Support the troops!



  9. #9

    small buttom

    Thanks, I hadn't noticed the small button in audio panel: "Multiplex audio" .... quite important



  10. #10
    Member bgryderclock's Avatar
    Join Date
    Dec 2006
    Location
    Charlotte NC USA
    Posts
    13

    Ubuntu 10.10 = export SDL_AUDIODRIVER=pulse && blender -g noaudio

    Audio scrubbing in Ubuntu 10.10 works with the terminal command:

    export SDL_AUDIODRIVER=pulse && blender -g noaudio
    -> EFF.org <- Support the troops!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •