Page 6 of 6 FirstFirst ... 456
Results 101 to 114 of 114
  1. #101
    I'm betting there's a file somewhere that allows you to set export environmental variables for your Terminal - in Linux, it would be called ".bashrc" or ".profile" and would be in the user's home directory...


  2. #102
    Member scorpion9's Avatar
    Join Date
    Aug 2005
    we...i just downloaded it,but it doesnt seem to work.
    as i run the script, it just closes the blender, with no error message. nothing.
    Why does life exist only on earth?
    Because God used Bugged script for Importing Universe.
    "Error, unable to import Module.Life()!
    This may cause some serious problems.
    Do you want to continue?

  3. #103
    Run it from a terminal and post the output, please.


  4. #104
    Member Eidam655's Avatar
    Join Date
    Oct 2006

    i'm just curious - how long does a simple 3 object scene (together ~29k triangulated faces) in orthogonal mode render? my render progress seems to stop at

    ('Creating the camera frustum...',)
    ('Frustum culling...',)
    has the script finished working? the CPU is at 100% load for more than 15minutes, and since i have an intel graphics card (the (in)famous 945GM :P ), blender does not redraw correctly and i can't even check whether it responds because of the CPU load.

    any info highly appreciated; keep up the good work.
    oh! a signature!

  5. #105

    The frustum cull can be buggy with certain camera setups - what version are you running?


  6. #106
    Member Eidam655's Avatar
    Join Date
    Oct 2006
    yes, i've read that it must have no geometry behind the camera, but maybe it's yet another set up.

    i'm using pantograph 0.5 with blender 2.49a and python 2.6.2

    i can post results with the bleeding edge version till tomorrow, would that be helpful?
    oh! a signature!

  7. #107
    Member Eidam655's Avatar
    Join Date
    Oct 2006

    the renderer will pass through frustum cull seamlessly in bleeding edge version

    now i am waiting for the final output; current progress is "Sorting 2d faces into BSP tree..." and billions of dots ^^ will let you know whether succesful

    EDIT: alright, i killed it :-D with 1GB of RAM all of it is eaten up by pantograph renderer + another ~280MB in swap. maaybe i'll leave it working tomorrow, but today i'd rather do something else than just watch the laggy progressbar

    and yes it got stuck (not stuck, working) on the sorting thing.

    EDIT 2: i worked on the mesh a bit and removed the faces which wouldn't be rendered anyway, and OMG taht's a speedup there's been one mysterious segfault after an autosave, but hasn't occured ever since, so what the heck.

    thanks, everything is working.
    Last edited by Eidam655; 12-Aug-09 at 04:50.
    oh! a signature!

  8. #108
    hello there,
    I was recently trying to set up the bleeding edge version on my vista computer,
    and I found out this bug ('progressImage faild to load')
    I know that Stani mentioned this a bit earlier.
    My coding skills are not very proficient and I dont know realy what to do about it,
    so please can you give me a tip how to fix it?

    thank you in advance

  9. #109
    Hi, I'm trying to install Pantograph on Windows for a couple of hours with a little success only. I already have a Render->Pantograph menu entry but rendering fails because it can't find cairo

    Compiled with Python version 2.6.2.
    Checking for installed Python... got it!
    Reloading pantographConfig
    Cairo library not found - you will not be able export to PDF or PNG formats, or
    preview renderings
    Traceback (most recent call last):
    File "<string>", line 1, in <module>
    File "D:\Blender\.blender\scripts\Pantograph\pantograph .py", line 37, in <modu
    import pantographLib
    File "D:\Blender\.blender\scripts\Pantograph\pantograph", line 1930, in
    class Pen(RGBA):
    File "D:\Blender\.blender\scripts\Pantograph\pantograph", line 1939, in
    NameError: name 'cairo' is not defined

    My installation:

    Windows XP SP 3
    Blender 2.49a
    Python 2.6 -> D:\Blender\.blender\scripts\Pantograph\
    pycairo for py2.6, tried versions 1.4.12-1, 1.4.12-2, 1.8.6
    cairo as part of GIMP2.6.8 : HOMEDIR = os.path.normpath("D://Blender/.blender/scripts/Pantograph")

    set PYTHONPATH=%PYTHONPATH%;D:\Blender\.blender\script s\Pantograph\;D:\Python26\Lib\site-packages\cairo

    set Path=%Path%;D:\Program Files\GIMP-2.0\bin

    I restarted PC btw. You say that PyGTK, Polygon and ming-python are not essential, I have however installed PyGTK and Polygon too, but that didn't make a difference.

    What could be wrong?

    Thanks a lot
    Last edited by Tapaka; 06-May-10 at 08:30. Reason: update

  10. #110
    Really no idea? I'm stuck...

  11. #111
    is there a short video showing what this can do


  12. #112
    Silence I found only two ways of exporting from Blender to SVG:

    - - a single script which didn't work at best for me and I don't recall where I got it actually from

    - Pantograph

    So I'm afraid I'm stuck here because need to get a SVG output (or other Inkscape compatible output, if you have a tip please share!!). I just seem too moronic in the Python/GTK/Blender environment and can't find out why the hell I can't bind cairo! (see above) Please can anyone give me advice on what to check specifically? Really thanks

  13. #113
    Join Date
    Nov 2004
    Does anyone know of an alternative these days, in 2014?

  14. #114
    one year has passed, where can I find panograph or alternative solution?

Page 6 of 6 FirstFirst ... 456

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts