Results 1 to 9 of 9
  1. #1

    WebM/VP8 encoding under Ubuntu 10.10 (without terminal)...?

    I'm about to encode my new project for online distribution and want to use the open-source VP8 (WebM) codec. Currently Blender does not do this, the best I found is a command line solution for Ubuntu 10.10 http://worldofursus.blogspot.com/201...untu-1010.html but I have no clue how to use this code (how to tell the terminal where my folders are...?).

    Is there are simple programme that does WebM encoding, works out of the box under Ubuntu 10.10 and offers a user friendly way of encoding to WebM...? (Unfortunately Avidemux does not seem to do this.)

    Thanks for any tips!



  2. #2



  3. #3
    Originally Posted by yellow View Post
    Handbrake?
    Ok I managed to install Handbrake - copy paste code from this blog entry: http://www.jonathanmoeller.com/screed/?p=2592 - yet it seems Handbrake does not accept my folder with rendered pngs. It seems to need video.

    I would need a programme that combines those 5726 final rendered frames with a .wav audio track and gives me WebM (VP8) that plays back at least in a current VLC version.

    Anyway thanks for the tip! Just let me know if I'm missing the obvious here and could use Handbrake after all...



  4. #4
    kdenlive has presets for rendering to WebM.

    In the end though, learning to use the terminal app will always give you the most flexibility and control. (Creating your own render presets in kdenlive for instance, requires understanding how to use ffmpeg's terminal interface)



  5. #5
    Originally Posted by FishB8 View Post
    kdenlive has presets for rendering to WebM.

    In the end though, learning to use the terminal app will always give you the most flexibility and control. (Creating your own render presets in kdenlive for instance, requires understanding how to use ffmpeg's terminal interface)
    Thanks! You are right, Kdnlive does VP8. However there seems to be an issue with exporting single frames, the render gets stuck at 99%. I now registered with the Kdnlive forum and found someone else who (just posted) update: *weeks ago* posted his/her second message and seems to have a similar problem:

    http://www.kdenlive.org/forum/rendering-image-sequences

    So my quest for VP8 encoding goes on, but it seems I'm "99%" there...
    Last edited by indiworks; 24-May-11 at 05:44.



  6. #6
    I just tried it with a short image sequence without any such problem. I think your use of "Add Slideshow Clip" might be the issue. Use "Add Clip" instead, but be sure that you tick the "Import Image Sequence" check box at the bottom of the open file dialogue.



  7. #7
    Originally Posted by FishB8 View Post
    I just tried it with a short image sequence without any such problem. I think your use of "Add Slideshow Clip" might be the issue. Use "Add Clip" instead, but be sure that you tick the "Import Image Sequence" check box at the bottom of the open file dialogue.
    I can't seem to find the "Import Image Sequence" check box in Kdenlive (version that comes with Ubuntu 10.10)...?

    Now your comment inspired me and I went back to OpenShot after finding this:

    http://www.openshotvideo.com/2011/01...detection.html

    Basically "Import Image Sequence" does exist in OpenShot (I had overseen that one first), however when I try to use it I get:

    "Validation Error! At least 2 images must match the file name pattern in the selected folder."

    Now I have 5000+ frames with long file names, I guess the next step here would be to rename the pngs via Blender and try again... However it seems that OpenShot does not have VP8 export at this point.

    Will have another look at Kdenlive options, but my feelings is that this is not working at the moment...

    Anyway thanks!



  8. #8
    I'm not sure what version of kdenlive is offered with Ubuntu 10.10. I use Gentoo and built my own. Version I am using is the latest (0.8).

    See attached image.

    Click image for larger version. 

Name:	imgseq.jpg 
Views:	113 
Size:	64.8 KB 
ID:	142176



  9. #9
    Originally Posted by FishB8 View Post
    I'm not sure what version of kdenlive is offered with Ubuntu 10.10. I use Gentoo and built my own. Version I am using is the latest (0.8).

    See attached image.

    Click image for larger version. 

Name:	imgseq.jpg 
Views:	113 
Size:	64.8 KB 
ID:	142176
    This is different to what I see, that last option does not seem to be there for me... (if it's not a graphic/display problem and might be cut off somehow).

    I currently don't have access to my Linux PC, but will check this again at the beginning of next week when I'm back!

    After my last attempt with OpenShot as mentioned above ("validation error") I now tend to think that the problem I have with all of this, in Kdenlive as well as my failed attempts of doing this via Terminal (in regards to pngs from Mencoder: "Sorry, this file format is not recognised."...?!), I now tend to think (or hope) that this all has to do with the long file names my final renders have, e.g.:

    space_visual_v2_200511_pngs_960_final_no_overpaint _0001.png

    I'll rename them via Blender and will try again with a very short file name in Kdenlinve, OpenShot as well as via Terminal and will post back results till mid-next week at the latest!

    Thanks a lot for your tips so far!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •