Results 1 to 7 of 7
  1. #1

    Shadow color problem

    Hi all,

    I use Blender 2.63 on a iMac (Intel 64Bit).
    I have a simple plane and placed a simple cube on it. I added a sun lamp. Under the shadow settings for the lamp I changed shadow color to grey.
    If I render now the cube causes a grey shadow on the plane as expected. So far no problem.
    Then inside the material settings for the plane under section 'Shadow' I enabled 'Shadows only'.
    If I render again the shadow is black not grey anymore :-(.

    How can I change the color of the shadow if I enable 'Shadows only' for the plane?

    Background is I want to use compositor to combine a real photo with objects created inside Blender. The shadows in the real photo are grey not black. So I want to make my objects cast also grey shadows. But of course the plane itself should be invisible, therefore I enabled 'Shadows only'.
    But unfortunately this causes the shadow to turn to black, not grey.

    Ist it a bug?

    Thanks for any help!



  2. #2
    Member J_the_Ninja's Avatar
    Join Date
    Sep 2010
    Location
    Portland, OR, USA
    Posts
    1,677
    Why not just adjust the blending opacity of the shadow pass while compositing? It'll probably take some trial and error to get the right shade of gray anyhow, might as well do it with the opacity where you get realtime feedback instead of having to re-render.



  3. #3
    Hi J_the_Ninja,

    thanks for reply, yes I could try that.
    But I still need to know if this is a bug inside Blender or a lack of knowledge from my side.

    Thanks for further help.



  4. #4
    It's not a bug, it's doing what it's supposed to do. The shadow only option only affects the materials alpha value so the properties of the lamp, like intensity of colour will not affect the result you get. This allows you to use the compositor to give whatever final result you want with the shadow.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Screen Shot 2012-07-14 at 13.44.16.jpg 
Views:	75 
Size:	32.1 KB 
ID:	188768  

    Last edited by Richard Marklew; 14-Jul-12 at 07:48.



  5. #5
    Member Atom's Avatar
    Join Date
    Jan 2006
    Location
    Ohio
    Posts
    11,637
    You can also just lower the alpha of the plane to achieve your grey.



  6. #6
    Hi,

    Richard and Atom. Thanks for reply, I am not that familiar with the node editor. Can someone provide a quick screenshot of node-settings?
    This would be great, thanks!



  7. #7
    Hi, I put together a small tutorial on how to render shadows in blender,
    http://zeroset.wordpress.com/2012/09...n-blender-2-6/
    you may find all necessary settings there.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •