Results 1 to 4 of 4
  1. #1

    Trouble getting path following with a navmesh to work

    I have a cube that's supposed to follow a human mesh (the player of my game) and I'm trying to use a steering actuator with path finding connected to an always sensor. I've generated a navigation mesh and the actuator is supposed to target the human mesh and the navmesh is set to the correct mesh. Both of them are obstacles and dynamic. If I have it set to "seek" it will move toward the human and work correctly, but as soon as I change the behavior to path following it won't move at all. I have the "visualize" box checked and it shows a red and a green line on "seek" but it shows nothing on "Path following."
    Any ideas?



  2. #2
    Member Cotaks's Avatar
    Join Date
    May 2012
    Location
    The Netherlands
    Posts
    1,054
    target the human mesh and the navmesh is set to the correct mesh. Both of them are obstacles and dynamic
    Obtacle is only needed if u activate obstacle engine in the world tab.
    The player should be dynamic or whatever u want, but the navmesh must be set as navmesh and not as dynamic.
    instead of navmesh being dynamic make the object that needs to follow the player dynamic.

    Always -> and ->steering (set to path finfing)
    select navmesh and target and it should work.



  3. #3
    As far as I can tell, all those are correct. I've attached my .blend and a picture, because I'm stumped.
    Game%20World2.blendBLENDERPROBLEM.png



  4. #4
    Member Cotaks's Avatar
    Join Date
    May 2012
    Location
    The Netherlands
    Posts
    1,054
    Select your navmesh, go to physics tab, click clear data then reset index value.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •