Results 1 to 13 of 13
  1. #1

    Feedback loop detected when baking a texture

    I'm trying to follow a tutorial here to bake a texture: The directions say to make a new image map in the uv image editor and then bake. I keep getting "feedback loop detected" and the image map of a previous ambient occlusion map appears but it's black. Can someone tell me what I am doing wrong to make a texture image map of my dragon? I included a screen shot to help explain what I mean. I also included a link to the blend file.

  2. #2
    i am guessing you are trying to bake an image texture to itself. you need to create a fresh ( blank ) image file from blender to bake to, then be sure to save it before closing.
    nodes tutorial on 'stenciling':
    nodes tutorial on custom sequence wipe:

  3. #3
    Thanks for responding. I deleted all my textures and uv image files to try again. I made a fresh blank image file. I'm assuming you have to unwrap the low-poly dragon first. Then I right click select the multi-res dragon on layer two, then shift select the low-poly dragon on layer one. Then I bake. I don't get any bumps on the image map. I wonder if when I shift right click the low-poly dragon if both dragons are supposed to be selected. Because it seems like only the low-poly dragon is selected. Could this be what I am doing wrong?

  4. #4
    @Blanco111 I think it's a bug. I have this same problem, and bake normal in Blender 2.63. It's works fine. Try to bake model on one layer.

  5. #5
    I downloaded 2.63 and tried it and still can't get it to work. I tried it on one layer, too. I discovered both of my dragons are being selected by simply going to wire frame mode. But I still can't bake normals. Ambient Occlusion and Texture baking work fine, but I must be doing something wrong with normals baking. It doesn't seem that complicated which makes it even more frustrating. Thanks for your input anyway.

  6. #6
    I have a thought. Try applying scale ( ctrl A ) to both objects first.
    (edit) in rereading my post, it sounds sarcastic but that is not intentional
    Last edited by Modron; 31-Dec-12 at 23:20.
    nodes tutorial on 'stenciling':
    nodes tutorial on custom sequence wipe:

  7. #7

    Baking Normals on a dragon doesn't work

    No luck with ctr A scale, rotation and location. I did an experiment. I made a new blender file. I used the default cube. I moved it to layer two. I applied the multires modifier to it (which made it round.) I then duplicated the multires cube and moved the duplicate to layer one. I then removed the multires modifier from the cube in layer one. With the now low poly cube in layer one, I marked the seams, unwrapped it, and made a new image of it. Then I selected the multires cube in layer two, shift selected the now low poly unwrapped cube in layer one. Then I baked the normals. And it worked! When I follow the same steps for an added cube in one of my dragon blend files (layers 3 and 4) I get an error message "No objects or images found to bake to." When I follow the same steps to bake the normals for the dragon (layers one and two), I get a purple image map, but no relief of the bumps show.

    This is a link to a screen shot of the successful baking of the normal map onto the low poly default cube in a new blend file.

    This is a link to the new blend file where I successfully bake the normals for the default cube (above):

    This is a link to the blend file with the dragon (layers one and two) and added cube (layers three and four). I can't bake the normals in this blender file.

    I had been unable to upload a blend file showing the dragon because when I used the multires modifier, the file got too big (50 MB). For some reason, that's not happening now, so hopefully a more experienced blender user out there can look at my blend file and tell me why I can't bake the normals on my dragon. Note: I deleted most of my other attempts at map images and also the ambient occlusion and texture images in the dragon blend file in the link.

  8. #8
    Join Date
    Oct 2012
    Budapest, Hungary
    same error message here

  9. #9
    Sorry to hear that. I never was able to do that particular step in the tutorial. Also, my modeling didn't come out too good either. Good luck!

  10. #10
    This is very serious problem indeed. Is there some other way to bake normal maps? Maybe in cycles?

  11. #11
    it's actually not hard to fix you just have to create a new texture, and bake to it before using it anywhere else, so that it is exclusive for the bake then you wont get such problem

  12. #12
    I find that when I have this problem I can get it to work by switching the textures off in the textures panel prior to baking. You can then turn them back on again afterwards. This issue usually arrises from trying to bake to a texture that is already in use on the low-res model.

  13. #13
    Member powlly's Avatar
    Join Date
    Apr 2012
    BC Canada
    Hi Blanco111, I have had that same error message "feedback loop detected" and it turned out I had doubles in my model. So not sure if this helps but, select all verts and on your key board w and remove doubles, it worked for me so just thought I would share.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts