Results 1 to 18 of 18
  1. #1
    Member DrKoil's Avatar
    Join Date
    May 2015
    Location
    Nevada, USA
    Posts
    4

    .Blend files not using preview thumbnails in windows explorer

    Hi, I'm kinda new to the forums so I'm not 100% sure if this is the right place to post.

    I've been using blender for about 4 years now. Ever since I first started using it, all my .blend files have had little preview images in the icon in the windows explorer. I found this feature really useful because I save hundreds of copies of the same file as backups, and I always want to know which file is which without having to open blender 50 times before getting the right file.

    But just a week ago, I got a new computer. I downloaded the newest version of Blender (v2.74) and everything worked fine--except those file previews.

    I've tried searching on google plenty of times, but I can't find anything that would help.
    And no, this isn't just happening on a few files. It doesn't show up for any of them.

    I really don't know what to do. I don't know if this feature was removed or...

    Any help is appreciated.



  2. #2
    Member
    Join Date
    Jul 2014
    Location
    Copenhagen
    Posts
    718
    Hi

    I can't help You with windows explorer.....But..if You don't know there is a new feature in Blender file Browser...We can now see thumbnail view in file browser of Blender file...)
    Just turn it on in the browser.

    Tai



  3. #3
    See if it's disabled in User Preferences/File/'Save preview Images' , maybe you need to re-save the old files in 2.74.
    Or you need to enable show thumbnail for files in the OS.
    Last edited by ramboblender; 31-May-15 at 16:34.



  4. #4
    Member DrKoil's Avatar
    Join Date
    May 2015
    Location
    Nevada, USA
    Posts
    4
    Originally Posted by Taipan View Post
    Hi

    I can't help You with windows explorer.....But..if You don't know there is a new feature in Blender file Browser...We can now see thumbnail view in file browser of Blender file...)
    Just turn it on in the browser.

    Tai
    Well... I didn't think about this before. Although, I'd prefer the thumbnails in the normal file browser. I just find it faster that way.

    Suppose this could be one way around the problem though. I'll see.

    Originally Posted by ramboblender View Post
    See if it's disabled in User Preferences/File/'Save preview Images' , maybe you need to re-save the old files in 2.74.
    Or you need to enable show thumbnail for files in the OS.
    1. It's already enabled.
    2. Already tried re-saving the files
    3. Already looked at the settings for windows explorer. It was checked by default.



  5. #5
    Member victornsy's Avatar
    Join Date
    Aug 2013
    Location
    Singapore
    Posts
    17
    Anyone have solution to this? I am using 2.76b and there is no thumbnail on my windows explorer.
    I think sagethumb screw it up after I installed it. After I uninstall sagethumb the thumbnails still
    wouldn't show.



  6. #6
    Originally Posted by victornsy View Post
    Anyone have solution to this? I am using 2.76b and there is no thumbnail on my windows explorer.
    I think sagethumb screw it up after I installed it. After I uninstall sagethumb the thumbnails still
    wouldn't show.
    Sagethumbs seems to screw a lot of things up, but I don't think that's it. I reformatted recently and installed the latest version of blender on a basically clean system, and they still don't work. At this point I would REALLY like someone to clarify what's going on with thumbnails in file explorer, because this is important to my workflow and it's been absent/bugged for some time now.
    Last edited by Guy112; 21-Dec-15 at 09:51.



  7. #7
    Member
    Join Date
    Sep 2009
    Location
    Florida
    Posts
    89
    THIS IS THE FIX

    This appears to be a bug in the Blender installer, but the fix is fairly simple.

    Open the Windows icon in the bottom left corner of your computer display and search for "command prompt"

    Right click on the result and select "run as administrator."

    There will be a small window with a black background and a blinking cursor.

    Type "chdir c:\program files\blender foundation\blender" and press Enter (chdir is the command for changing directories with the command prompt)

    You should now be at that directory.

    Type "blender -R" and press enter. You should receive a message indicating that the registration has been successful.

    Close any Windows Explorer windows and then open Windows Explorer again.

    Navigate to a directory that has your blend files and you should now see thumbnails for all of your blend files. If there some blend files that don't have thumbnails, it's probably an old file before the thumbnails were added. Just open and save it again and you should see the thumbnail.

    I'm not sure why Blender Foundation hasn't fixed this instalation problem by now. I'm wondering if you have to install blender as an administrator to get it to regiser the thumbnail dll.

    Anyway, until it gets fixed, you will likely have to register as described above with every new installation.
    Last edited by fmb501; 21-Dec-15 at 12:31.



  8. #8
    fmb501: Worked perfectly, thank you SO much!



  9. #9
    Member
    Join Date
    Sep 2009
    Location
    Florida
    Posts
    89
    Guy112: It took me a long time to figure it out. The posts on the Internet and Stack Exchange on this subject are not helpful.

    Glad I was able to help someone with the same problem I had.



  10. #10
    Member victornsy's Avatar
    Join Date
    Aug 2013
    Location
    Singapore
    Posts
    17
    Originally Posted by fmb501 View Post
    Guy112: It took me a long time to figure it out. The posts on the Internet and Stack Exchange on this subject are not helpful.

    Glad I was able to help someone with the same problem I had.
    The method you posted did not work for me on my end. However I found a second work around,
    Here it's is for those who need another way round it.

    Just go download an earlier version blender 2.66a or such and install it on your computer. The
    previous installation packages would register the .blend extension properly. Well since I may
    sometimes wanna use an eariler version of blender to do importing of obj file, as I found the latest
    version of blend tends to screw the surface normals and randomly add edge creast setting to the
    imported models.

    @ fmb501 : You may wanna mark this topic as solved.



  11. #11
    Member
    Join Date
    Mar 2010
    Location
    São Bernardo do Campo, SP, Brazil
    Posts
    3
    "THIS IS THE FIX" posted by "fmb501" works perfectly !
    Thank you SO much!



  12. #12
    Member
    Join Date
    Sep 2009
    Location
    Florida
    Posts
    89
    Originally Posted by paulopatrocinio View Post
    "THIS IS THE FIX" posted by "fmb501" works perfectly !
    Thank you SO much!
    Glad it worked for you.



  13. #13
    fmb501 Thanks so much! this works perfectly now!

    Sage thumbs broke it in the first place. (and never gave me gimp thumbnails like it promised).

    No i just need a way to get GIMP thumbs and I will be totally set




  14. #14
    Member chombor's Avatar
    Join Date
    Mar 2016
    Location
    Russian Federation
    Posts
    36
    Originally Posted by fmb501 View Post
    this is the fix

    this appears to be a bug in the blender installer, but the fix is fairly simple.

    Open the windows icon in the bottom left corner of your computer display and search for "command prompt"

    right click on the result and select "run as administrator."

    there will be a small window with a black background and a blinking cursor.

    Type "chdir c:\program files\blender foundation\blender" and press enter (chdir is the command for changing directories with the command prompt)

    you should now be at that directory.

    Type "blender -r" and press enter. You should receive a message indicating that the registration has been successful.

    Close any windows explorer windows and then open windows explorer again.

    Navigate to a directory that has your blend files and you should now see thumbnails for all of your blend files. If there some blend files that don't have thumbnails, it's probably an old file before the thumbnails were added. Just open and save it again and you should see the thumbnail.

    I'm not sure why blender foundation hasn't fixed this instalation problem by now. I'm wondering if you have to install blender as an administrator to get it to regiser the thumbnail dll.

    Anyway, until it gets fixed, you will likely have to register as described above with every new installation.
    it wooooork!!!11



  15. #15
    Member Brontobyte's Avatar
    Join Date
    Sep 2016
    Location
    Cody Wyoming
    Posts
    76

    Blender Stand Alone

    Originally Posted by fmb501 View Post
    THIS IS THE FIX

    This appears to be a bug in the Blender installer, but the fix is fairly simple.

    Open the Windows icon in the bottom left corner of your computer display and search for "command prompt"

    Right click on the result and select "run as administrator."

    There will be a small window with a black background and a blinking cursor.

    Type "chdir c:\program files\blender foundation\blender" and press Enter (chdir is the command for changing directories with the command prompt)

    You should now be at that directory.

    Type "blender -R" and press enter. You should receive a message indicating that the registration has been successful.

    Close any Windows Explorer windows and then open Windows Explorer again.

    Navigate to a directory that has your blend files and you should now see thumbnails for all of your blend files. If there some blend files that don't have thumbnails, it's probably an old file before the thumbnails were added. Just open and save it again and you should see the thumbnail.

    I'm not sure why Blender Foundation hasn't fixed this instalation problem by now. I'm wondering if you have to install blender as an administrator to get it to regiser the thumbnail dll.

    Anyway, until it gets fixed, you will likely have to register as described above with every new installation.

    " If you want to make Blender fully standalone, without the app setting a section in Roaming department, create config folder where you have Blender residing: ie. X:\Users\xyz\Desktop\blender-2.78.0-git.9bea39c-win
    "
    IT worked here as well... in my D drive I have blender alone so it does not have this weird config situation where its pulling a config from my users account.

    NO what Happend is I typed in Blender-R and that is different than Blender -R bzzzzzt ! Ok anyhoo more people know how to make blender a stand alone.



  16. #16
    Wow, I was looking for a thumbnail viewer for all my 3D and here I find out Blender already supports it!!! Does anyone know of if it is possible to get the same thumbnails views for exports such as fbx or obj? I found a stl viewer though I don't really use that file. Also thanks Bontobyte for mentioning their is weirdness when its configured on another user account, that explains my trouble at work, at least that's what I believe you mean about the standalone and roaming subjects.



  17. #17
    Darn, actually on my work computer it doesn't matter which user name I'm under, after I put in "blender -R" it still gives me this

    C:\WINDOWS\system32>blender -R'blender' is not recognized as an internal or external command,
    operable program or batch file.

    Does anyone know how to fix this?



  18. #18
    Originally Posted by NWNWN View Post
    Darn, actually on my work computer it doesn't matter which user name I'm under, after I put in "blender -R" it still gives me this

    C:\WINDOWS\system32>blender -R'blender' is not recognized as an internal or external command,
    operable program or batch file.

    Does anyone know how to fix this?
    You propably have blender installed with steam? The file path is different try this.

    chdir C:\Program Files (x86)\Steam\steamapps\common\Blender

    (press enter now)

    then

    blender -R
    Last edited by fiendish55; 28-May-17 at 02:50.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •