Page 27 of 27 FirstFirst ... 17252627
Results 521 to 529 of 529
  1. #521
    Originally Posted by matali View Post
    SSS and Volumetrics patch are already done and the work from the paid AMD dev is available in a branch. But it needs to be optimized. https://git.blender.org/gitweb/gitwe...s_split_kernel. This branch now works on all devices, not only AMD, so you should be able to mix devices soon.
    Thanks, this is a good news. So we'll see in couple of months a stable release?



  2. #522
    Originally Posted by Jholen View Post
    Thanks, this is a good news. So we'll see in couple of months a stable release?
    https://wiki.blender.org/index.php/D...gested_targets it is planned for 2.79 together with speedups.
    Specs: 2x RX480, i7 6700, 16GB of DDR4



  3. #523
    Member
    Join Date
    Oct 2012
    Location
    UK, England
    Posts
    418
    Originally Posted by matali View Post
    SSS and Volumetrics patch are already done and the work from the paid AMD dev is available in a branch. But it needs to be optimized. https://git.blender.org/gitweb/gitwe...s_split_kernel. This branch now works on all devices, not only AMD, so you should be able to mix devices soon.
    Have you checked on this? Because i built the split kernel branch a few days back and still heavily broken. All you get is solid purple renders, and last time i checked blender dev where code updates and patchs live,Mai (who is in charge of doing the split kernel) was asking the original Opencl SSS and Volumes patch author if he had any ideas why SSS was not matching CPU SSS and that without that being fixed the patch would not be getting into master. And last time i checked neither SSS or Volumes were part of the Mai split kernel branch.

    I think your making things up from what i know, try not to spread false info on here about opencl, just makes people complain when things dont pan out.



  4. #524
    SSS and volumetrics patch work when applied on master branch not mai's branch as far as I know. Didn't test it in the last weeks as I don't use those functions in real projects.
    Regarding Mai's branch, it works on the RX480 at least and she codes on a Firepro W9100, so I guess it works on the older generations too. If you experience bugs like pink textures, report it on the tracker, not on the forum.
    Mai's branch doesn't bring any speedup for me at least on the RX480, but huge memory savings. In my test scene, memory usage goes from 2GB to 1200MB which is really great.



  5. #525
    Member
    Join Date
    Oct 2012
    Location
    UK, England
    Posts
    418
    Originally Posted by bliblubli View Post
    SSS and volumetrics patch work when applied on master branch not mai's branch as far as I know. Didn't test it in the last weeks as I don't use those functions in real projects.
    Regarding Mai's branch, it works on the RX480 at least and she codes on a Firepro W9100, so I guess it works on the older generations too. If you experience bugs like pink textures, report it on the tracker, not on the forum.
    Mai's branch doesn't bring any speedup for me at least on the RX480, but huge memory savings. In my test scene, memory usage goes from 2GB to 1200MB which is really great.
    Hey Dude, Hope your still working on your speed up patch.

    I Also have a Fire Pro W9100 16GB GDDR5, I compiled the Mai brach and it doesnt render with purple textures, The whole tile just renders purple. Compiled that branch 3-4 times over the last couple weeks and always had this result so i dont know what to tell you.

    Im on Windows, Maybe your on Linux? But i can guarantee you it does NOT work on Fire pro W9100 on windows.

    Alos the SSS and vilumes patch doesnt work bud, Not at least in the way it should. Volumed fine, SSS renders very different from CPU. Kinda works, enough to use if just for a one off render. But if on a project where CPU and GPU renders will be mixed it is completely different.

    CPU SSS Cycles:
    Name:  ear1.png
Views: 336
Size:  133.6 KB

    GPU SSS Opencl:
    Name:  ear2.png
Views: 336
Size:  133.4 KB

    Exact same scene, No changes other than ONe was on CPU and other on Opencl GPU. Very Very different results.
    Last edited by 3DLuver; 16-Feb-17 at 16:23.



  6. #526
    Member mib2berlin's Avatar
    Join Date
    May 2008
    Location
    Germany
    Posts
    3,403
    Hi, I read in #blendercoders the developer has a patch nearly finished to fix the SSS issue, after review it is ready for master.

    Cheers, mib
    OpenSUSE Leap 42.1/64 i5-3570K 16 GB Blender 2.7 Octane 3.03
    GTX 760 4 GB, GTX 670 2 GB Driver 375.26 | Blender for Octane



  7. #527
    @3DLuver My patch is a bit on hold because I have a lot to do. But the 15-20% speedup patches are in review since more than 4 month now, so if it continues like that, it's better anyway if you build yourself or use the builds I provide (the up to 40% speedup build is here https://blenderartists.org/forum/sho...speedup-thread available)
    Regarding Mai's branch, I'm on Linux yes. Speak with her on IRC or report a bug on the patch tracker https://developer.blender.org/D2348
    On an end note, I never saw a patch or test file from you, but you speak a lot about what should or could be done and how. Just do it and provide patches. Better be a constructive part of the community. If 3 people work on improving OpenCL, it will go much faster.



  8. #528
    Member
    Join Date
    Oct 2012
    Location
    UK, England
    Posts
    418
    Here's a few quick Branch's a put together for people:

    The latest denoise branch's on git blender are screwed, thats why their isnt any new builds. But i get the feeling Devs are now starting to hide their updates and not even put them on Blender dev, Or git blender. This adds to the point i was making that Blender dev is broken, If branch's that are supposed to be latest are not the real work then clearly like i said devs are getting fed up with patch's and updates sitting around for 3-4 months to even get evaluated that their now not even bothering.

    Split Kernel on Git-Blender has been broken for ages, tried it 3-4 over the last few weeks but just solid purple tile renders. Then Blibblubli points me to a new .Diff rather than the branch on git blender. I checkout todays master, Aptly the .Diff and compile and works fine. Do i need to say anything more about the state of Blender Dev right now.

    So, As im a helpful person here is a working copy of MAI's Brilliant start at the New Split kernel for CPU, Cuda, OpenCL. Even though i only have an AMD card, Ive decided to now start building all my new builds with cuda as well. After Nvidia showing in new drivers they are GOING to start supporting Opencl 2.0 ill now start giving them a little more respect. Now all they need to do is open source their Physics API and ill treat them the same way i do AMD.

    https://mega.nz/#!1hQmETTb!XcE-NMEen...77Fmx-zua6aY7g

    Please Opencl and Cuda / CPU users test this branch. It's what will end up in master sooner or later, Feed back now will be very very helpfull.

    Blibblubli, Mate ive been fixing your original patch for weeks, Trying to get working right with current master builds. Your original patch was great, But as i guess you know with you update with the 40% attempt speedup ANY changes to main render code or Post Pro system just breaks your update.

    On one of my test branch's i added the AA post pro node fron blender dev, Also the new noise nodes. As soon as i try to add any other support to post pro system it destroys the speed gain and actually makes render slower than master. Which i think i stumbled across a major issue with blender cycles render and post pro system code.

    So i noticed by adding post pro nodes then destroyed your patch advantages i removed the whole post pro system from cmake, so no post pro within the blender install, Yet the node code update for AA and new noise in post pro even when not included in the build still destroyed your patch. I would say that maybe what we need to do at this point as part of the split kernel update is completely split Post pro render and node features from main render and nodes system. By removing the post pro setup from the build the render speed regretion from those post pro nodes should of made a change. but just pure render without post pro even built still affected the outcome.

    Post Pro system and nodes NEEDs to be separated from Render and nodes setup. From looking at your update that really did speed things up for me originally, It still could in future but your have to keep on top of any changes made to the node shader system to stop being broken. Hope your willing to do that because clearly there are speed gains to be made by evaluating the node system ordering, but it's something that will need constant change to make sure you get the speed.

    So again here's another build id did quickly, Last Denoise build that worked with the most current master at the time, Mixed with Sample Scramble system that really does speed things up if used right, Added that to main render setup not just experimental settings tab, And your original fast nodes update that's been sitting on blender dev for 3-4 months.

    https://mega.nz/#!5wwyxLBb!Fbnu5tqHb..._mCFYPxXpDU7rk

    DO NOT TRY TO ENABLE DENOISE WITH THIS WHEN RENDERING WITH OPENCL, YOU WILL GET A BLUE SCREEN OF DEATH.

    Your doing a great job so don't get disheartened by the ridiculously slow code updates and patch's system right now. Sooner or later someone will decide it has to change.
    Last edited by 3DLuver; 20-Feb-17 at 19:08.



  9. #529
    Member
    Join Date
    Sep 2012
    Posts
    1,986
    3DLuver,
    Thanks for the builds.

    Does OpenCL works OOB with/on nvidia cards? Any special condition, setting to take care of?

    Will test & report back.
    bye



Page 27 of 27 FirstFirst ... 17252627

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •