Page 12 of 12 FirstFirst ... 2101112
Results 221 to 236 of 236

Thread: Auto-rig Pro [3.21]

  1. #221
    This is simply awesome, great work. Question is how to rig the eyes. The eyes are 2 separate objects, tried joining together but did not work, only one eye was rigged. Thanks for your help and a kick but addon!



  2. #222
    Thanks for the advice on the mouth, I ended up modeling it with the mouth slightly opened, seemed to work well. New facial markers are also awesome.


    I'm having an issue with the bend in the elbow, just wondering if there is any way to fix this?


    Basically the bones are rotated and so the elbow isn't bending in the correct direction. Trying to edit the reference bones doesn't seem to help as the orientation is just reset once the rig is matched.


    Also just as a minor feature request it would be nice if when using the "Reset All" button on the proxy picker if it reset the finger grasp values back to zero.



  3. #223
    Member lucky's Avatar
    Join Date
    Jul 2006
    Location
    3D world
    Posts
    205
    @ewilliams2: Thanks for the feedback! Make sure the eyeballs object only contain the "c_eye.l" and "c_eye.r" vertex groups, and check the assignment.

    @aMars: You're welcome, I'm glad it helped! The arms/legs roll is not editable. It's calculated when clicking Match to Rig. The reason is IK-FK chains does not support custom roll. You can adjust the end result though, by changing the elbow reference bone position:

    ik_roll.jpg


    Right about the reset grasp. It will be fixed.



  4. #224
    Adjusting the elbow joint fixed it, much thanks



  5. #225
    Sorry one more question, why did you delete the images with the weight paints for limbs from the documentation? Are they not relevant anymore?



  6. #226
    Member lucky's Avatar
    Join Date
    Jul 2006
    Location
    3D world
    Posts
    205
    You guessed it right, i've included an automatic smoothing of the twist bones a few months ago.



  7. #227
    Not sure if this is a known issue or not, but I ran into an odd situation with this addon.

    I have been working on a very large scene with a lot of objects (2.2mil verts, 2,000+ objects) and noticed that my performance was fine when I didn't select anything, but any time I selected an object other than a camera or lamp, performance would totally tank. I'd have ~5-15 seconds of lag on any action until I deselected everything and cleared the active object (or selected a lamp or camera.) After many days of trying to figure out why selection mattered for performance, I tried disabling all my addons on the off chance that it was somehow one of them. And that fixed it! So then I turned them back on one by one to find the culprit, and it is AutoRigPro!

    Disabling autorigpro addon solved my performance issues in this large scene. I assume that the addon must be looping through a bunch of objects whenever I make a selection or something? Is there any way to fix this? I want to use AutoRigPro with characters in complex scenes, so it would be great if there's a fix!
    Non-Photorealistic Rendering and basic character tutorials:
    http://www.aversionofreality.com/



  8. #228
    Member lucky's Avatar
    Join Date
    Jul 2006
    Location
    3D world
    Posts
    205
    Hi Oscalon,

    I can't reproduce this issue here. Tested with a scene including 4,219,148 faces, 1371 objects. It runs fine with all the addons enabled (proxy picker, auto-rig-pro...).
    However I've experienced in the past some similar lag, but not related to any addon. I had to display an empty layer to clear the viewport cache, and the laggy effect was gone.



  9. #229
    This is an AWESOME TOOL! Thank you so much! I will be downloading once home. Just wondering if there are any plans on adding full body IK solver features (fingers crossed and hopes high!).


    Best Regards;
    David



  10. #230
    Originally Posted by lucky View Post
    Hi Oscalon,

    I can't reproduce this issue here. Tested with a scene including 4,219,148 faces, 1371 objects. It runs fine with all the addons enabled (proxy picker, auto-rig-pro...).
    However I've experienced in the past some similar lag, but not related to any addon. I had to display an empty layer to clear the viewport cache, and the laggy effect was gone.
    It is certainly being caused by AutoRigPro in my particular case. But of course, it's a complicated setup with a ton of different parts interacting with each other. There may be some other components involved contributing to the problem. I will let you know if I can figure anything else out.
    Non-Photorealistic Rendering and basic character tutorials:
    http://www.aversionofreality.com/



  11. #231
    Purchase made, Yay!
    I do lots of motion capture, Perception Neuron, PrioVR and IPIsoft. Have a few projects coming up and desperately needed a motion capture workflow in Blender.
    Last edited by dfblem1; 07-Sep-17 at 23:14.



  12. #232
    Hello, every time I go to Remap this step, import Bvh file, Retarget, will be wrong, I do not know where the wrong, I carefully read the document, I am confused is the skeleton of the map, I modified the bvh Bone name, and auto tig pro generated the same, but still error, please give me a solution to the idea. thank youImage.pngImage2.png



  13. #233
    Hi!
    Learning the add-on. So far rigging was fast, even with some manual editing of bone placements. The rig generated with no issues, other than parenting the shoulders to the spine bone. Right now, I'm just waiting for Remap to finish transferring some motion capture data, data captured from the Perception Neuron. Some time has gone by, close to 5 minutes or more. Wondering if something could be wrong, using Blender 2.79 release candidate 2.

    Update!
    Transferred completed. Arms, hands, fingers and body are animating perfectly, Yay!
    The long transfer time was just due to having a long motion capture sequence, lol.

    But, the legs are the issue, bummer.
    desktop.jpg

    Update#2
    Legs fixed, thanks Lucky!
    Last edited by dfblem1; 12-Sep-17 at 08:33.



  14. #234
    Member lucky's Avatar
    Join Date
    Jul 2006
    Location
    3D world
    Posts
    205
    @dfblem1 Thank you David, I hope you'll enjoy! Just turn to FK mode the legs since you did not used IK retargetting.

    @Oscalon:Thanks for reporting and sending a blend file, it's now fixed :-)



  15. #235
    Screen04.jpg
    Hi!

    I also picked up the Additive Keyer addon, It's awesome. the ability to animate over the mocap in a non-disruptive method is huge, able to push, pull, correct and adjust with out screwing up the mocap data, is welcomed in any animation studio .




    Thanks Lucky!
    Best Regards;
    David



  16. #236
    Member lucky's Avatar
    Join Date
    Jul 2006
    Location
    3D world
    Posts
    205
    Thanks for your feedback David, i'm glad it's useful to you!



Page 12 of 12 FirstFirst ... 2101112

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •