Page 1 of 3 123 LastLast
Results 1 to 20 of 41
  1. #1

    OpenCL denoising and speedup thread

    Attachment 479538
    A build with OpenCL Denoising working and some speedup patches from Nirved is available. With it, the classroom scene renders in 7min30 on a RX480 compared to 6min30 with a 1080. So a 200€ card is nearing the perf of a high end card.
    With Denoising on at default, it takes 8min15 and is noise free.
    The build is available here: https://gum.co/CMIu .
    You can donate what you want. It will help me to continue working on the OpenCL performance.
    Last edited by bliblubli; 08-Apr-17 at 05:53.



  2. #2
    Member
    Join Date
    Oct 2012
    Location
    UK, England
    Posts
    484
    Hey Bud, This build doesn't work for me. addons get error messages and dont work.

    Question, Is this the old patch build you put on blender devs forums a while back? And what new features does it have, you say has new features but no specifics on what.

    If you really want to help out OpenCL users we would love bake support to be fixed to work with openCL with GPU, I dont know the Blender code base nearly well enough yet to start on that.



  3. #3
    Originally Posted by 3DLuver View Post
    Hey Bud, This build doesn't work for me. addons get error messages and dont work.

    Question, Is this the old patch build you put on blender devs forums a while back? And what new features does it have, you say has new features but no specifics on what.

    If you really want to help out OpenCL users we would love bake support to be fixed to work with openCL with GPU, I dont know the Blender code base nearly well enough yet to start on that.
    Just re-downloaded the link, it works perfect for me. Did you unpack all the files in a clean directory?
    Finishing the split kernel, including SSS, volumetrics, baking, etc... is in the todo list of the paid dev from AMD (Mai who did the microdisplacement stuff). So I'll let her do her job.

    This build has full selective feature/node compilation. Meaning only what is really required is put in the kernel. But it's an old version of the patch, because the new one only work properly on Linux. To make people have fun in the meantime, I give this build again to test on latest drivers and latest cards. The times should be comparable to the next version.

    With this build and one big tile on RX480, windows 7 and Crimson 16.12.1 at stock clock, I get:
    - 3min14 on BMW 35^2 spp compared to 4min15 on master.
    - 1min05 on BMW from https://blenderartists.org/forum/sho...-(Updated-BMW)
    - 10min28 on the classroom scene at 300spp compared to 16min04 on master
    - 12min07 for Barcelona at 1000 spp compared to 18min42 on master
    Last edited by bliblubli; 28-Jan-17 at 15:52.



  4. #4
    It works on my rig. 390x

    BMW27.blend 400 samples. 1min02. The bmw scene has this purple reflection.
    purple.png

    - 11min31 on the classroom scene at 300spp
    - 12min31 for Barcelona at 1000 spp
    Last edited by bigbad; 28-Jan-17 at 17:18.



  5. #5
    Member
    Join Date
    Oct 2012
    Location
    UK, England
    Posts
    484
    Originally Posted by bigbad View Post
    It works on my rig. 390x

    BMW27.blend 400 samples. 1min02. The bmw scene has this purple reflection.
    purple.png

    - 11min31 on the classroom scene at 300spp
    - 12min31 for Barcelona at 1000 spp
    The build actually ran on my machine but you seem to have the same issue i was having, I had the same purple but in my terrain scene was much more prevalent as was also the only hdri light source, The HDRI skies plugin i use wouldn't load and gave error messages.

    Blender makes the environment light or textures that are missing purple on purpose to make clear something isn't right.

    So instead of just purple reflections i got purple lighting over the whole scene. Clearly in this build environment lighting is not right.

    @Blibblubli with out the patch (.Diff) i cant test or fix this, Without the code update i cant compile my own version to deal with it
    Last edited by 3DLuver; 28-Jan-17 at 20:34.



  6. #6
    Guys please read. The time I take to do support here for people not reading, I'm not programming.

    To all : Purple light/reflection: UNPACK THE TEXTURES
    . It is already solved in current patch, but it doesn't work properly on windows, so use workaround in the meantime.



  7. #7
    Originally Posted by bigbad View Post
    It works on my rig. 390x

    BMW27.blend 400 samples. 1min02. The bmw scene has this purple reflection.
    purple.png

    - 11min31 on the classroom scene at 300spp
    - 12min31 for Barcelona at 1000 spp
    Hi Bigbad, can you compare with master when you unpacked the textures ?



  8. #8
    Member
    Join Date
    Oct 2012
    Location
    UK, England
    Posts
    484
    Originally Posted by bliblubli View Post
    Guys please read. The time I take to do support here for people not reading, I'm not programming.

    To all : Purple light/reflection: UNPACK THE TEXTURES
    . It is already solved in current patch, but it doesn't work properly on windows, so use workaround in the meantime.
    Blibblubli, My scene doesnt have any packed textures, but it does use environment HDRI lighting for the scene. The plugin that provides this does not work with your build and gives errors in the addon:

    Blibblubli_build_environment_issues.JPG

    You have issues with Environment lighting in this build mate.



  9. #9
    Originally Posted by bliblubli View Post
    Guys please read. The time I take to do support here for people not reading, I'm not programming.

    To all : Purple light/reflection: UNPACK THE TEXTURES
    . It is already solved in current patch, but it doesn't work properly on windows, so use workaround in the meantime.
    I tried the 'External Data' unpack files but blender keeps crashing. Even the official blender. Strange.

    I'm on win 10.



  10. #10
    Opencl SSS on GPU cant render texture...render black!



  11. #11
    Originally Posted by Doisy Didier View Post
    Opencl SSS on GPU cant render texture...render black!
    SSS is not supported in cycles OpenCL yet. This build doesn't add functionality, it just optimizes what is already done.

    @Bigbad I'll submit a benchmark pack to test with all configured well to ensure everybody reports the comparable results.



  12. #12
    updated the first post with a link to the files to benchmark: http://dropcanvas.com/fdcvh . THey have textures unpacked and tile size set to get 1 big tile. The rest is like the official benchmark pack.
    @3D Luver. Indeed, HDrI is not working on this build. Will be working in the next one.



  13. #13
    Thank you bliblubli. I'll test it right away and report back.



    Optimized build:

    - 3min07 on BMW 35^2 spp
    - 1min02 on BMW 20^2 spp
    - 11min31 on the classroom scene at 300spp
    - 12min20 on the barcelona scene at 1000spp



    Regular blender:

    - 4min04 on BMW 35^2 spp
    - 1min21 on BMW 20^2 spp
    - 15min37 on the classroom scene at 300spp
    - 17min20 on the barcelona scene at 1000spp
    Last edited by bigbad; 30-Jan-17 at 01:01. Reason: updating benchmarks compare to master



  14. #14
    Originally Posted by bigbad View Post
    Thank you bliblubli. I'll test it right away and report back.

    - 3min07 on BMW 35^2 spp
    - 1min02 on BMW 20^2 spp
    - 11min31 on the classroom scene at 300spp
    @Bigbad, your welcome. Can you compare to master?



  15. #15
    Originally Posted by bigbad View Post
    Thank you bliblubli. I'll test it right away and report back.



    Optimized build:

    - 3min07 on BMW 35^2 spp
    - 1min02 on BMW 20^2 spp
    - 11min31 on the classroom scene at 300spp
    - 12min20 on the barcelona scene at 1000spp



    Regular blender:

    - 4min04 on BMW 35^2 spp
    - 1min21 on BMW 20^2 spp
    - 15min37 on the classroom scene at 300spp
    - 17min20 on the barcelona scene at 1000spp
    I get about the same times with RX480 Would have thought the 390X is faster.
    - 3min12 on BMW against 4min10 on master
    - 11min12 on classroom vs 15min45 on master
    - 12min08 on barcelona vs 17min39 on master.
    Specs: 2x RX480, i7 6700, 16GB of DDR4



  16. #16
    This build does seem faster, but the GPU still doesn't actually seem to be utilized significantly more than with regular builds. I have a Radeon RX480 4GB and the GPU power draw is about ~88W while rendering with this build. With the latest official one it's ~82W. With Luxmark this is about 101W. In games this gets to about 130-135W and with Furmark it can get as high as 190W or more.

    I used average values over several seconds for "GPU Chip Power" probed with HWInfo64.



  17. #17
    Member
    Join Date
    Dec 2007
    Location
    Wroclaw, Poland
    Posts
    214
    That I have to say is a nice improvement. Seems my R9 290x will still have a bit of life it in.

    Also, as Nvidia does technically support OpenCL, I'm curious to see the results there. Still have an older GTX 680 that I could use for extra rendering power. (I know CUDA is faster, just be nice to render a still with all the available resources that I have in one go.

    Still. This is really getting intresting.

    @ s12a, thanks for the power readout. Wonder if that is just on GPU core only, or full card. (probably the former) And still 88W.. will compare that to my r9 290x too using HWInfo64 when I can
    Dell T5600 x2 Xeon X5-2687w + 32GB ECC + R9 Fury + R9 290x + SSD goodness



  18. #18
    @Grzesiek: that's GPU core only, as far as I am aware of.



  19. #19
    Originally Posted by s12a View Post
    This build does seem faster, but the GPU still doesn't actually seem to be utilized significantly more than with regular builds. I have a Radeon RX480 4GB and the GPU power draw is about ~88W while rendering with this build. With the latest official one it's ~82W. With Luxmark this is about 101W. In games this gets to about 130-135W and with Furmark it can get as high as 190W or more.

    I used average values over several seconds for "GPU Chip Power" probed with HWInfo64.
    Yes, there is still a lot of room for speed improvements, but it's already a good speedup isn't it? The good point is that you can lower your voltage in the meantime. I run Cycles with 0.97v (easy to change in the new crimson app), the card is quiet even when rendering.



  20. #20
    It's a nice speed up, true. I was more pointing at the potential margins for improvements in GPU utilization. I haven't lowered voltage across tests to make GPU core power draw results comparable, I wasn't concerned with efficiency.



Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •