Results 1 to 4 of 4
  1. #1
    Member Jansiotropic's Avatar
    Join Date
    Mar 2012
    Location
    Utrecht
    Posts
    9

    NLA properties, set blend to Add acts strange. Can not set track influence in dope sh

    Hi,

    I have attached a blend with a simple tube with 2 bones. I made 2 actions on same bone : GoRight and GoUP. I tried to combine these 2 to let the moving part of the tube to go obliquely upwards.
    When i choose for blending: add (in both tracks), it works but the affected mesh gets 4 times as big. Why is that ?
    And i can not set the animated influence, it jumps back to 0 when ticked. Why is that ?

    In another model i could set the animated influence via the dope sheet (with kind of keyframes).

    Can someone help me out ?test_NLA_tube.blend



  2. #2
    Member Hadriscus's Avatar
    Join Date
    Apr 2012
    Location
    Massilia, France
    Posts
    1,288
    Hi,

    you keyframed the scale values as well.
    Animating influence works but it needs a checkbox in the n panel (in NLA) for some reason.

    Hadrien



  3. #3
    Member Jansiotropic's Avatar
    Join Date
    Mar 2012
    Location
    Utrecht
    Posts
    9
    Thanks Hadriscus,

    I keyframed LocRotScale indeed. But I didn't do anything with the scale. The scale during animation was just 1. I deleted the scale channels and it works now. Looks like blender adds the scale values (when setting blending to Add), so 1 + 1 = 2 as the resulting scale.
    For animating influence I had to tick the chekbox, go to the dope sheet and put keyframes in the influence NLA strip control channel.

    Thanks,
    Jan



  4. #4
    Member Hadriscus's Avatar
    Join Date
    Apr 2012
    Location
    Massilia, France
    Posts
    1,288
    Well yep if it's add and both are 1, result is 2. For influence you can directly key the value slider as well.

    Hadrien



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •