Results 1 to 2 of 2
  1. #1
    Member
    Join Date
    Apr 2014
    Location
    San Diego, CA
    Posts
    35

    I need your help with importing BVH onto model's armature please

    Hello fellow Blenders, I need your help.
    I finally set up the sensors to record me swinging a stick around. I successfully exported my efforts into a BVH file. I opened Blender and made a low-poly model and created a blank armature rig. I imported the bvh file, after tweaking it on the bvhacker app. I assigned the specific bones from the imported bvh onto the blank rig. Even though the collar bones are pushed back, for the MOST part, it did a good job copying the rotation from the import onto the blank rig, shown here:
    Click image for larger version. 

Name:	SearDSe.png 
Views:	12 
Size:	63.7 KB 
ID:	487789
    So then I went to add the ARMATURE modifier onto the model, assigned bones via weight painting... And it's coming out to look like this...
    Click image for larger version. 

Name:	ouu3iXy.png 
Views:	10 
Size:	89.9 KB 
ID:	487790
    I'd really appreciate if you guys take a look at the file and tell me what I did wrong... and what I can do to prevent further mistakes.

    Thanks in advance guys!
    Here's the file.
    Windows 10 64-bit | Intel Core i7-3770K CPU @ 3.50 Ghz quadcore | 16GB RAM | NVIDIA GeForce GTX 970 | 4096 MB Graphics Memory



  2. #2
    Member stilltrying's Avatar
    Join Date
    Oct 2011
    Location
    Tampa, Fl
    Posts
    508
    You have unapplied scale. Scale your armatures in edit mode only. You scaled them in object mode. Then when you parent them it will try to maintain scale. Unparent mesh. Clear your transforms Alt S, r, and G on your armatures. Go to edit mode and adjust. Then reparent.
    It's amazing how many ways you can achieve desired results in Blender!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •