Results 1 to 5 of 5
  1. #1

    Fluid Simulation going through obstacle

    I'm currently trying to make a bowl with water in it. So I cut off the top of a sphere, put another sphere on top of it and scaled it a little down, took a cube and set it all up (fluid domain, fluid and fluid obstacle). After baking I got this (around frame 100):
    Click image for larger version. 

Name:	2017-09-11 17_02_04-Blender.png 
Views:	178 
Size:	30.4 KB 
ID:	497958

    So why does the fluid don't flow into the bowl?



  2. #2
    I assume the game is for us the guess all the fluid settings you have set for the fluid, domain and all obstacles rather than just supply a link to your .blend file we could just look at.

    Check the object face normals are pointing in the correct direction.
    Apply scale to all objects
    Does the fluid go through the obstacle or pours over the top of it (check if obstacle is set to a volume or shell
    Vary domain resolution (also set to show the final resolution and not the draft resolution)



  3. #3
    So I guessed it on my own, I had to turn the Volume Initialization type from the bowl to shell but thank you for answering



  4. #4
    I have a similar question - in my case the fluid penetrates the thin walls during splash regardless of whether I use only the walls I mean or add a different, thicker mesh. Resolution is at 200 already, I don't think I want to go too high on that. To avoid making a new thread I put it here.

    http://pasteall.org/blend/index.php?id=47836



  5. #5
    New User
    Join Date
    Dec 2017
    Location
    USA
    Posts
    1
    If you are having trouble with fluid passing through thin walls during a fluid simulation then you can disable "Remove air bubbles" in the Fluid Boundary settings for your Domain object.

    If you are rendering an opaque object, such as a coffee mug, then no further steps should be required.

    If you are rendering a transparent object, then it is possible that you will also need to increase your Resolution settings, otherwise you will indeed have "air bubbles" in your render. The "remove air bubbles" setting is a great idea, but unfortunately it seems to work very poorly.

    The below image has "remove air bubbles" turned off and Final resolution set to 32. You can clearly see the air pockets (the interior of the cup is just a slightly curved cylinder, not that weird shape).

    I've done a few tests with this scene, and the air pockets remain all the way up to 128 resolution, but they are barely noticeable. At 256 resolution, they are not noticeable, but fluid simulation is very slow.

    This may have something to do with how many times my cup has been subdivided. My guess is that the air bubbles go away once the surface geometry of the water is smaller than the surface geometry of the interior of the cup. That's just a guess though, and I have not tested it.

    Click image for larger version. 

Name:	32render.jpg 
Views:	2 
Size:	59.8 KB 
ID:	509835



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •