Results 1 to 13 of 13

Thread: Incredibly slow viewport, Ubuntu 16.04 LTS, Nvidia 1050ti

  1. #1

    Incredibly slow viewport, Ubuntu 16.04 LTS, Nvidia 1050ti

    My computer seems like it should be able to handle a lot of geometry, but it chokes on even the simplest scenes.

    My specs:

    Dell t5500 with dual 6 core xeons.
    24 GB RAM
    Nvidia 1050ti with 4GB VRAM
    Ubuntu 16.04.3 LTS
    Blender 2.78c
    Nvidia driver 375.66

    I have a scene with roughly 350K tris in it. The viewport is laggy as hell. My 2012 Mac mini with integrated graphics spins the same scene like it was butter.

    Clearly something is not right, but I am not very well equipped to figure out where to start debugging it. I am pretty sure that I am using the proprietary Nvidia drivers (I have the NVIDIA X Server Settings tool installed and it runs). It says when I spin the object that the GPU is hitting about 4% utilization.

    It also says that the card is plugged into a Gen2 PCIe slot, x16 with a Max speed of 5.0GT/s

    Thermal settings seem to hover around 40 degrees C

    PowerMizer: It has Adaptive Clocking Enabled. It stays at level 2 (min 202 MHz max 1974 MHz) Setting it to :Prefer Max Performance does nothing.

    Even the menus are dog slow. There is a quarter to half second delay between my mouse hovering over a menu and it being highlighted. Again, the exact same scene on my Mac Mini is buttery smooth.

    Does anyone have any ideas how I would go about debugging this? I also am running Mudbox on this machine (not at the same time) and it seems to open the same geo and spin it without issue. Subdividing it and trying to sculpt does get a bit slow so I don't know if this is a system issue or a Blender specific issue. Any tips greatly appreciated!

    Thanks!


    Edit:

    Just updated to the latest Nvidia drivers with no improvement
    Last edited by bvz2000; 13-Sep-17 at 00:09.
    New to Blender and even newer to modeling. Trying to learn by doing: https://blenderartists.org/forum/sho...orcycle-so-far



  2. #2
    Originally Posted by bvz2000 View Post
    My computer seems like it should be able to handle a lot of geometry, but it chokes on even the simplest scenes.

    My specs:

    Dell t5500 with dual 6 core xeons.
    24 GB RAM
    Nvidia 1050ti with 4GB VRAM
    Ubuntu 16.04.3 LTS
    Blender 2.78c
    Nvidia driver 375.66

    I have a scene with roughly 350K tris in it. The viewport is laggy as hell. My 2012 Mac mini with integrated graphics spins the same scene like it was butter.

    Clearly something is not right, but I am not very well equipped to figure out where to start debugging it. I am pretty sure that I am using the proprietary Nvidia drivers (I have the NVIDIA X Server Settings tool installed and it runs). It says when I spin the object that the GPU is hitting about 4% utilization.

    It also says that the card is plugged into a Gen2 PCIe slot, x16 with a Max speed of 5.0GT/s

    Thermal settings seem to hover around 40 degrees C

    PowerMizer: It has Adaptive Clocking Enabled. It stays at level 2 (min 202 MHz max 1974 MHz) Setting it to :Prefer Max Performance does nothing.

    Even the menus are dog slow. There is a quarter to half second delay between my mouse hovering over a menu and it being highlighted. Again, the exact same scene on my Mac Mini is buttery smooth.

    Does anyone have any ideas how I would go about debugging this? I also am running Mudbox on this machine (not at the same time) and it seems to open the same geo and spin it without issue. Subdividing it and trying to sculpt does get a bit slow so I don't know if this is a system issue or a Blender specific issue. Any tips greatly appreciated!

    Thanks!
    I wonder what the exact CPU models are in the PC. I fail to find specifications for Xeon 5600 series with 6 cores. The clock speed may be low and single thread performance might be very poor. It's a server CPU - my suspicion is that it might not be that good for a workstation. Well, it might be something else still because it probably should not be as slow as described just because of the processor anyway.



  3. #3
    Member YAFU's Avatar
    Join Date
    Mar 2013
    Posts
    2,771
    Hi.
    Please share the result of the following commands from the terminal:
    Code:
    lspci | grep -iE 'vga|3D'
    Code:
    cat /proc/driver/nvidia/version
    (That just in case, according to what you say apparently nvidia driver is correctly loaded)

    Did you try with blender factory settings? Have you tried Blender 2.79?

    And also please, always use official Blender tar.bz2 file to do the tests (it's portable build)
    Last edited by YAFU; 13-Sep-17 at 08:50.
    Be patient, English is not my language.



  4. #4
    Hello,

    Thanks for the replies. Sorry I didn't reply sooner myself, I was at work all day.

    Here is the output of the first command:

    Code:
    04:00.0 VGA compatible controller: NVIDIA Corporation Device 1c82 (rev a1)
    And the second command:

    Code:
    NVRM version: NVIDIA UNIX x86_64 Kernel Module  384.69  Wed Aug 16 19:34:54 PDT 2017
    GCC version:  gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.4)
    New to Blender and even newer to modeling. Trying to learn by doing: https://blenderartists.org/forum/sho...orcycle-so-far



  5. #5
    Originally Posted by MartinZ View Post
    I wonder what the exact CPU models are in the PC. I fail to find specifications for Xeon 5600 series with 6 cores. The clock speed may be low and single thread performance might be very poor. It's a server CPU - my suspicion is that it might not be that good for a workstation. Well, it might be something else still because it probably should not be as slow as described just because of the processor anyway.
    The CPU's are dual 6 core x5675's. They should be more than capable of handling this kind of a load I think.

    My Mac Mini has a 2.5 GHz i5 in it and it blows my Dell out of the water. I suspect that somehow either Blender or my Ubuntu system as a whole isn't properly set up.
    New to Blender and even newer to modeling. Trying to learn by doing: https://blenderartists.org/forum/sho...orcycle-so-far



  6. #6
    Member YAFU's Avatar
    Join Date
    Mar 2013
    Posts
    2,771
    Drivers are correctly loaded. Please test with official Blender 2.79 with clean user configuration (factory settings):
    https://www.blender.org/download/

    Unpack tar.bz2 file to a folder, and run "blender" file inside that folder (double click).
    Be patient, English is not my language.



  7. #7
    Originally Posted by YAFU View Post
    Drivers are correctly loaded. Please test with official Blender 2.79 with clean user configuration (factory settings):
    https://www.blender.org/download/

    Unpack tar.bz2 file to a folder, and run "blender" file inside that folder (double click).
    Thanks for the confirmation. I'll try to do that tonight. If not tonight, then tomorrow. I'll report back. Thanks for taking the time to help!
    New to Blender and even newer to modeling. Trying to learn by doing: https://blenderartists.org/forum/sho...orcycle-so-far



  8. #8
    Originally Posted by bvz2000 View Post
    The CPU's are dual 6 core x5675's. They should be more than capable of handling this kind of a load I think.

    My Mac Mini has a 2.5 GHz i5 in it and it blows my Dell out of the water. I suspect that somehow either Blender or my Ubuntu system as a whole isn't properly set up.
    Yeah, you are right. They should really not be a problem at all. You could try disabling hyper-threading to see if that has any effect. It might improve performance of single thread noticeably. It might be a good idea to have it off when working while when rendering it's better to have it on. But it's probably not that likely that it would solve the main issue.



  9. #9
    Thanks for that hint. I *may* try that, but I am not super excited about the idea. I purchased this machine so that I could get as many threads as possible for my main rendering package which is Clarisse. Blender is a very useful tool and, so far, integral to my workflow but it is secondary to Clarisse and, if necessary, I will suffer the poor performance (or use my Mac Mini) instead of hobbling my primary renderer.

    But I appreciate the suggestion and if I get a moment I might try it out.
    New to Blender and even newer to modeling. Trying to learn by doing: https://blenderartists.org/forum/sho...orcycle-so-far



  10. #10
    Originally Posted by bvz2000 View Post
    Thanks for that hint. I *may* try that, but I am not super excited about the idea. I purchased this machine so that I could get as many threads as possible for my main rendering package which is Clarisse. Blender is a very useful tool and, so far, integral to my workflow but it is secondary to Clarisse and, if necessary, I will suffer the poor performance (or use my Mac Mini) instead of hobbling my primary renderer.

    But I appreciate the suggestion and if I get a moment I might try it out.
    Should not happen, though think its a bug in automatic gl setup. Try different "selection" and/or "Depth Picking" settings in sys prefs of blender.

    Jens



  11. #11
    Quick update. My machine is currently in pieces (I am switching from Ubuntu to CentOS fro reasons other than this issue) and so I haven't been able to try the new version of Blender yet. Once it is back up (one way or another I have to be running by tomorrow evening) I will do the install.

    Thanks again.
    New to Blender and even newer to modeling. Trying to learn by doing: https://blenderartists.org/forum/sho...orcycle-so-far



  12. #12
    Ok, so this is going to be an unsatisfying update for anyone suffering from the same issue (because I don't have a definitive solution), but it is a total win for me.

    I switched to CentOS 7. As part of that process I had to re-install the Nvidia drivers. I also updated my blender to 2.79.

    One (or more) of those things fixed it. My blender sessions are flying now.

    Thanks again for the help! It was super super useful.
    New to Blender and even newer to modeling. Trying to learn by doing: https://blenderartists.org/forum/sho...orcycle-so-far



  13. #13
    Ok, final update.

    I had to boot back into my Ubuntu distro (just swapped in my old HD) to get some data. While I was there I decided to try out 2.79 and see if that fixed the problem. Turns out, it did. So thanks for that! If anyone else is having similar issues, I would start with upgrading to 2.79 as a first step.

    Thanks again for all your help everyone.
    New to Blender and even newer to modeling. Trying to learn by doing: https://blenderartists.org/forum/sho...orcycle-so-far



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •