Results 1 to 11 of 11
  1. #1

    Smoke artifacts :(

    Hi at all - whenever im going to simulate smoke i ran into artifacts in the final rendering. Its exact the same probleme like here: https://blender.stackexchange.com/qu...ng-with-cycles
    But i cannot find any solution.
    The domain-scale has been applied!
    Anyone?
    Click image for larger version. 

Name:	b3iE0.png 
Views:	10 
Size:	702.4 KB 
ID:	498178



  2. #2
    Member YAFU's Avatar
    Join Date
    Mar 2013
    Posts
    2,953
    Hi
    Could you share a .blend file with the scene? Edit: Ok, I have file from youtube link
    Are CPU and GPU render the same?
    What value are you using for Resolution > Divisions in smoke domain?. Edit: seems 256 like in the other link
    Last edited by YAFU; 14-Sep-17 at 06:53.
    Be patient, English is not my language.



  3. #3
    Okay i made a new scene. Hopfuly someone can help me to find what im doing wrong here.
    ViewPort:Click image for larger version. 

Name:	Smokyfacts_Viewport.jpg 
Views:	6 
Size:	111.0 KB 
ID:	498301

    Renderd: Click image for larger version. 

Name:	Smokyfacts_rendered.jpg 
Views:	9 
Size:	66.2 KB 
ID:	498302

    BLEND: https://www.dropbox.com/s/rxt5xsij2h...cts.blend?dl=1



  4. #4



  5. #5
    Member YAFU's Avatar
    Join Date
    Mar 2013
    Posts
    2,953
    Hi
    Maybe report on tracker for developers to decide if this is a bug or something we are doing wrong?
    I've searched on google and people mention artifacts or square artifacts over there, but not on tracker.

    By the way, I'm not sure but I'd like to try bake the simulation with multithreading disabled. I am not sure if it is possible to globally disable multithreading in Blender.
    Be patient, English is not my language.



  6. #6
    Ive reported it as "maybe bug", now.
    Im not able to disable MT. Baking in general does not change anything.
    Ill wait if some developers can help and report here .
    Thank you YAFU!



  7. #7
    Member YAFU's Avatar
    Join Date
    Mar 2013
    Posts
    2,953
    Originally Posted by dafassi View Post
    Ive reported it as "maybe bug", now.
    I have the proof where developers tell me that when in doubt about whether the problem might or may not be a bug, it is always advisable to do the report

    Originally Posted by dafassi View Post
    Im not able to disable MT. Baking in general does not change anything.
    I have no idea about technical issues. It came to my mind that this could be a bad multi-thread implementation. I think this is because I remember that some similar artifacts appeared in images when multi thread was introduced in G'MIC filter for GIMP.

    I saw in the report that you did test with 512 resolution. Can I ask what CPU do you have? My i7 3770 suffers very much
    Be patient, English is not my language.



  8. #8
    Im working with a i7-5820k (6x3,4GHz) and 32GB RAM.
    Ill do some other tests, too. If i find any solution or developers can help ill let you know!



  9. #9
    try incrase subframe sampling on the sphere...



  10. #10
    Click image for larger version. 

Name:	mat_smoke.jpg 
Views:	9 
Size:	55.4 KB 
ID:	498529

    tweak the density with a ramp should help too, like this



  11. #11
    Hey Gritche, ive just tested this with subframes 50. There is nearly no differenece overall. But it was a good tip in general!
    You NodeSetup didnīt solve this issue- but it makes visible where the artifact are coming from! It because my smoke is very blocky ...
    Click image for larger version. 

Name:	Smokyfacts2.jpg 
Views:	12 
Size:	96.7 KB 
ID:	498600



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •