Results 1 to 5 of 5
  1. #1

    Strange artifacts with Musgrave texture

    I've been using Musgrave textures for years, but in 2.79, I am getting some ugly artifacts along the edges of the object. It doesn't happen in the preview render, only in the final render. Is anyone else getting this? It can easily be recreated by simply connecting a Musgrave texture straight into a diffuse shader.
    Click image for larger version. 

Name:	musgraveArtifact.png 
Views:	6 
Size:	684.4 KB 
ID:	507412



  2. #2
    Member JA12's Avatar
    Join Date
    Apr 2012
    Posts
    4,574
    Originally Posted by MeshHead View Post
    It can easily be recreated by simply connecting a Musgrave texture straight into a diffuse shader
    It could be recreated with an example .blend that you provide, which would also have denoising enabled.

    Negative values in the texture and denoising produces the artifacts. Remove negative values from the texture or disable denoising.
    Last edited by JA12; 07-Dec-17 at 05:53.
    New to BA.org and have a support question? Here's how to do that more effectively.



  3. #3
    Member
    Join Date
    May 2013
    Posts
    1,038
    If you plug musgrave into bump mapping, you'll see that it will often have data that goes well outside the visible 0-1 range. I've made my own node group to help preview the output and help scale it back into the 0-1 range for color use. I wish it had a (auto) normalize switch built in, but I don't think it's feasible.



  4. #4
    Member Ace Dragon's Avatar
    Join Date
    Feb 2006
    Location
    Wichita Kansas (USA)
    Posts
    28,423
    You can get everything into the 0-1 range by using the bright/contrast node and lowering the contrast value to about -0.750

    In addition, just to be sure, you can first pipe the result through a color mix or math node and tick the 'clamp' box.
    Sweet Dragon dreams, lovely Dragon kisses, gorgeous Dragon hugs. How sweet would life be to romp with Dragons, teasing you with their fire and you being in their games, perhaps they can even turn you into one as well.
    Adventures in Cycles; My official sketchbook



  5. #5
    Member
    Join Date
    May 2013
    Posts
    1,038
    The musgrave controls should really be greyed out if they are not applicable to the currently selected musgrave mode (without disconnecting the inputs of course, even if they don't do anything). Contrast might work in some cases, but in others (depending on settings you can get stupid high output values) I prefer my adjustment node where I can also preview clipping. With clipping preview enabled, I get black for n<0, white for n>1, and a grey constant for anything in between. Adjust measured values until all is grey, then turn off Clip Preview. Here is the node group setup:
    Click image for larger version. 

Name:	fValueNormalizer.jpg 
Views:	6 
Size:	242.9 KB 
ID:	507806



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •