Results 1 to 9 of 9
  1. #1

    Explosion has gray area in compositing

    Hi

    I'm creating a scene that involves a Blender explosion over an image background. I've a few other digital objects also in the compositor, but the explosion is the only thing not rendering onto the image background correctly; there is the gray 'default' background where the smoke domain box is located. How do I get rid of the gray and leave only the explosion?

    If it helps, I have two render layers and two view layers. The explosion is located on both views but only on the second render layer. Both the domain and the object exploding have a pass index of 2.

    Help would be greatly appreciated.

    Thanks,
    AerialBot



  2. #2
    So......

    No one?



  3. #3
    sample image or blend file???
    Over 40 shorts, three features. I am EL DIRECTOR
    indierebel.co - The ultimate VFX training with free software
    facebook.com/leap3movie - My latest film in progress



  4. #4
    Hi Director

    Here are two images. One is the explosion itself rendered on the image, and the second is the node tree.
    Name:  explosion.png
Views: 37
Size:  184.5 KB
    Click image for larger version. 

Name:	nodes.png 
Views:	5 
Size:	1.33 MB 
ID:	520849

    Thanks for your help.

    AerialBot



  5. #5
    Did you check the "Transparent" box under "Film" in the Render Settings tab?
    Over 40 shorts, three features. I am EL DIRECTOR
    indierebel.co - The ultimate VFX training with free software
    facebook.com/leap3movie - My latest film in progress



  6. #6
    As El Director said, checking "Transparent" would help eliminate the grey background. However, there will still be a problem, as the id mask for the box domain is still a box and not limited to the explosion volume itself. Since your explosion render layer includes other objects, this id mask will keep parts of those other objects as well, as you can see in your examples where the gray box includes a small amount of the brown ground in the bottom left.

    Having a separate render layer with only the explosion would likely help solve that problem, and eliminate the need for the id mask in this instance.



  7. #7
    Hi Director. Hi Mandalorian.

    I'll try that.

    Thanks,
    AerialBot



  8. #8
    Hi Director. Hi Mandalorian.

    Apparently, 'Transparent' only made the domain completely black. Then, I moved the explosion entirely to a third layer, created a third render layer, and rendered again ('transparent' still enabled). It works!

    . . . Now my node tree is all wonky and I have to fix it somehow.
    But! The domain problem is gone.

    Thanks!
    AerialBot



  9. #9
    Member
    Join Date
    Jan 2004
    Location
    Nashville, TN (USA)
    Posts
    6,790
    Oh, node-trees get pretty "wonky" pretty quick. But, if it works . . .



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •