Results 1 to 6 of 6
  1. #1

    No cloth simulation option in physics tab in blender 2.79

    I installed blender 2.79 via dnf install on Fedora 25. When I select an object and go to the physics tab, it shows only rigid body simulation. My son's computer does the same (also Fedora 25).

    Click image for larger version. 

Name:	blender-nocloth.png 
Views:	6 
Size:	135.8 KB 
ID:	521184

    (I do have the cloth modifier available.)



  2. #2
    Ensure you have not enabled 'Blender Game' from the top of the blender interface
    Ensure you have selected an object that can use a cloth simulation (not a camera, lamp, curve etc)

    Show us a screenshot of the whole blender interface including the physics settings and a blend file that demonstrates the issue



  3. #3
    Thank you for the response.

    Originally Posted by Richard Marklew View Post
    Ensure you have not enabled 'Blender Game' from the top of the blender interface
    Ensure you have selected an object that can use a cloth simulation (not a camera, lamp, curve etc)
    As the attached screenshot shows, I am on "Blender Render" not "Blender game", and I have selected a basic cube (created via shift-a, mesh, cube).

    Originally Posted by Richard Marklew View Post
    Show us a screenshot of the whole blender interface including the physics settings and a blend file that demonstrates the issue
    The screenshot is already attached to my initial post. I am attaching the blend file here: nocloth.blend

    Full steps to reproduce: Go to File/New. Use the default startup file containing a single cube. Click on the physics tab. Only "Rigid Body Tools" appears, nothing else.

    I don't know if the Fedora RPM is packaged without it? Is there a file I could look for in the RPM? I do have a (populated) directory /usr/share/blender/scripts/presets/cloth and a file /usr/share/blender/scripts/startup/bl_ui/properties_physics_cloth.py. Nothing else mentions "cloth". If I introduce an error in the latter file, it crashes on startup (good sign; it's being read.) If I insert
    Code:
    import pdb; pdb.set_trace()
    or
    Code:
    raise "hell"
    into PhysicButtonsPanel's poll() classmethod, it seemingly never gets called.



  4. #4
    Basically Physics Tab of toolshelf in 3D View editor was created for Rigid Bodies. It might evolve in future to welcome more buttons relative to other physics and addons.
    But most of physics were already there in 2.4x interface. And the only area available to place their parameters was Properties Window in 2.4x.

    So, to set-up a cloth simulation, you have to add cloth modifier to the object and look at Physics Tab of object in Properties Editor, not to properties column of 3DView.
    https://docs.blender.org/manual/en/d...es_editor.html



  5. #5
    Cloth simulator settings in physics panel (which you weren't showing in your screenshot which is why I asked for you to show the whole interface)

    For cloth simulator settings see https://docs.blender.org/manual/en/d....html#workflow

    Click image for larger version. 

Name:	Screen Shot 2018-04-15 at 12.52.15.jpg 
Views:	2 
Size:	227.2 KB 
ID:	521253
    Last edited by Richard Marklew; 15-Apr-18 at 06:59.



  6. #6
    Ah, sorry! I read several descriptions of how to do this, and they always referred to just "the physics tab", which I took to be the one on the left-hand side. I did not see the (graphical) physics tab because it was off the screen (I thought I *was* showing you the full UI.)

    Yes, this gives me what I needed. Thank you!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •