Results 1 to 6 of 6
  1. #1

    Bevel tool not working right: bevels coming out flat

    I'm having a problem with beveling some surfaces on detail parts on a project I'm working on.

    I'm using the bevel tool but the bevels come out completely flat, rather than curved or angled as they should be.
    Click image for larger version. 

Name:	flat-bevel.jpg 
Views:	7 
Size:	214.9 KB 
ID:	521314

    The bevel extends inward from the edge I'm wanting to bevel, and remains flat, as shown above.
    In this case I was trying to bevel the outer top edge, which is the bottom selected line in the image.

    The parts in question had holes in them carved out with the Boolean tool. I thought maybe that might be the issue and tried using the knife project tool, instead, but I still get the same problem. It's not my scaling either, as all 3 axes are at 1.000. I've tried cleaning up options, recalculating my normals, and other things. Nothing seem to resolve the issue.

    Any ideas as to what's causing this?
    Last edited by Crotalidae; 15-Apr-18 at 16:47.



  2. #2
    Member
    Join Date
    Sep 2012
    Posts
    3,197
    "Oh, holy satanic wisdom of crap..."
    Simply, post a file.



  3. #3
    bevel-problem.blend
    Originally Posted by burnin View Post
    "Oh, holy satanic wisdom of crap..."
    Simply, post a file.
    I didn't want to include the whole project, as it's pretty big. This is a file with the problem part, appended in.
    The issue still persists.



  4. #4
    right yeah that has some limits on it, if you turn on clamp overlap you can see that there is v. little room to bevel, bye selecting the whole loop though you can get what I think you want?

    bevel-problem-bevelled.blend



  5. #5
    Originally Posted by anadin View Post
    right yeah that has some limits on it, if you turn on clamp overlap you can see that there is v. little room to bevel, bye selecting the whole loop though you can get what I think you want?
    Do problems sometimes arise when trying to bevel a single edge, rather than than a whole loop like you suggest?

    I still don't understand *why* I can't bevel the (individual) edges there normally. I did try selecting the whole loop though, and it does bevel correctly.



  6. #6
    Member
    Join Date
    Sep 2012
    Posts
    3,197
    To bevel individual edge you would need to disconnect it from neighboring parts. I think this bevel operation in Blender is oldish and sort of simplistic. It would need to take into account near by (close) points, joining them at the center/first/last then beveling further... which, for now it has to be done manually.

    Otherwise, best is as suggested by anadin, to bevel whole loops. Keep the edges flowing.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •