1) Only one bone moving in animations 2) Subdivided bone not deforming mesh

Hi guys, I’ve got a couple of quick questions here. I’ve got a humanoid model with rigging and automatic weights, which is all working properly except for these two problems:

  1. When I scrub along the playback window, the bones are not animating unless I select and move them individually for each keyframe. For example: Say my human is standing straight up and I add a keyframe, then I kick his leg out and add another keyframe. The only way the leg will actually animate when I scrub between the two frames is if I go back to the first frame and nudge the leg a bit. Blender seems to be ignoring my first frame because I didn’t actually move the bones around in it. Does a bone have to be “initialized” before it will move in an animation?

  2. I subdivided the foot bone to add a toe bone, but the new toe bone will not deform the mesh. “Deform” is checked and the foot bone is parented to the toe bone.

Thanks for any assistance.

#1 - No, doesn’t need to be initialized, other than the initial keyframe. In you case, you say you have 2 keyframes, so you should see animation in the 3d view. Would need to see the file to look further into it.

#2 - Since you’ve added a bone after the weights have been generated, blender isn’t aware that the new bone should control anything because it doesn’t have any weight for the new bone. You need to do 1 of 2 things, either manually go in and add weight for the bone, or let blender do the auto weighting again. If you want to do it manually, you need to study up on how to ‘weight paint’ your mesh, look it up on the wiki user manual. If your going the auto weight route, you can simply clear the parent/child of the mesh & armature and re-parent it choosing the auto weights option. If you go this route, beware that when you parent an armature to a mesh, blender adds an armature modifier to the mesh. When you clear the parenting, blender doesn’t remove the modifier. So when you re-parent things, blender will add a 2nd armature modifier to the mesh. End result is you have 2 armature modifiers on the mesh, so the mesh moves 2x as much as the bone. Delete one modifier and it will act normally.

Randy

Ah, thanks a lot Randy. I fixed the second thing; I can probably just deal with the first thing, but if you’d like to look into it further I’ve attached the file.

[ATTACH]225565[/ATTACH]

Looked at the file, yes there are keyframes on frame 1 & 20, yet nothing happens. So I went into the armature panel, at the top of it, and switched the rig from rest position to pose position. Now the rig moves as expected. Rest position forces the rig into it’s default pose and ignores all animation data.

Randy

Oh I know it was currently in rest mode, that’s just how I happened to leave the file last before I sent it to you. That’s not the problem I’m referring to. In any case I think I’ve worked around my issue.