2.37 - What happened to my camera!!!!


Before, when I had a camera tracked to empty, pressing “g” and then hitting MMB would let me move it in and out towards or away from the empty.

Now in 2.37 everything is messing up and it seems to be defaulting to local Z which isn’t right.

How do I get back old functunality?

It seems for every feature, 2.37 has broken an important part of my workflow… /sigh

Any help on how to get the camera fly in/fly out back?

I’ve tried it also in 2.36 and also notice the difference. Seems like movement of the camera in local axis doesn’t work correct?

I think that was actually a bug with the camera. If you tried to constrain its movement to the z-axis while in camera view it would zoom in and out. Now it will follow the axis correctly. You can still have it “zoom” by grabbing the blue arrow in normal mode, but only outside the camera view. I’d prefer to have the old way back. It was much more convienient. Don’t know if you can or not though.
That’s my only gripe with 2.37, for every feature, it has improved my workflow…

I think I saw a similar post a sometime ago. In the camera view, with the camera selected, the hotkey to zoom in or out is g z z.

nope… G z z does what I am posting about, the incorrect thing.

Using the widget to move along normal actually does the correct thing, but it really is un-workable because A: I hate widgets and B: You can’t do it within the camera.

The nice thing about rotate trackball and zoom in/out was that you could easily place and rotate the camera easily to the view you want… now it seems that is impossible and framing your shots is 10000x more harder and un-workable unless there is a way to change this.

I think I will run both 2.36 and 2.37, use 2.37 for softbody perhaps, and then load everything back into 2.36 for animation, placement and rendering since it seems to be more user-friendly.

edit: sorry if I am sounding un-grateful all you coders, but I am a fan of improving a program without ruining its functionality… is there a reason that you needed to get rid of old trackball rotation(as far as just hitting MMB goes) and this Local Z / Normal camera stuff as the defaults instead of offering an option to somehow disable it?

It seems counter-intuative that I need to run older versions to get better functuality and features(being able to place camera from its own viewpoint is a BIG feature imho)?

Play with the new camera controls in 2.37… I think they are better and more intuitive.

I don’t get it. If your camera tracks the empty, Local Z (MMB in camera view) moves it toward or away from the empty, so what’s the problem?

The difference is that 2.37 uses stable motion, not continuous motion like before, so you never overshoot.

As far as rotate trackball goes, just press Rkey twice. MMB is now used for axis constraints is all the transforms that have them, so a big plus for consistency. I think that might be missing from the changelogs though, my bad.


Theeth, then I think I have a bug.

If I duplicate the camera twice so its in the same location with same local Z, then this is what happens:

Moving the camera with WIDGETS by LOCAL Z and NORMAL Z result in a correct movement, they go in and out away from empty and give good results.

However, Moving the camera both in and out of camera view, by either MMB or hitting “G Z Z” for local Z movement, gives incorrect movement that does not appear to be aligned with the actual camera’s local Z.

So what is happening, is that the widget local Z is correct and the “Gzz” local Z is incorrect.

Any idea’s? this looks to be a bug now…

Please post in the bugtracker on blender.org with an example file.

I can’t reproduce here.