2.37a + Python 2.4 : nervous reaction

Dear all,
I did the simplest possible thing: installed the last Python. Yes, 2.4.
Then, installed the last Blender, 2.37a.
Then updated PYTHONPATH, etc. Windows XP.

Launched Blender and got the console message:
“Using Python version 2.3
‘import site’ failed; use -v for traceback”

I understand that 2.37 has been compiled with the support of Py 2.3 (God
knows why…), but I didn’t expect immediately such reaction. Then,
Blender worked, scripts as well, but not all. Visible incompatibilities.

Anybody knows about the version of Blender compiled with Py 2.4? It
seems that it has been announced, after all this version of Python is
stable already some months…

And for goodness sake, what is this ‘import site’?
Truncated “site-packages/…” perhaps?
And, launching Blender with -v is slightly less than useful…
Unless I should somehow launch python with the flag -v ?..

Best regards.

Jerzy Karczmarczuk
Caen, France

Blender needs python 2.3. You can stop that nervous reaction now. %|

Thank you, but, please, READ my message. I told explicitly
that I KNEW that. So, little help…
Of course, I can install 2.3, I don’t need to bother people here.

I asked, also explicitly, about the version compiled with 2.4 support.
That is all I requested. Thank you.

Jerzy Karczmarczuk

How about this one?

http://www.blender.org/modules.php?op=modload&name=phpBB2&file=viewtopic&t=6356

Thanks, works. The Python23.zip collection of scripts is not replaced,
but first attempts at making my scripts work succeeded. No problems
with tupled import, non-recognition of the warnings module, etc.

You have been very helpful.

Jerzy Karczmarczuk

Well, I’ve never heard of a version compiled with 2.4 before, so that’s news to me as well. The point is, you’re getting overly agitated over nothing.

ybody knows about the version of Blender compiled with Py 2.4? It
seems that it has been announced, after all this version of Python is
stable already some months…

you can found a amd64bit version with Python2.4 here on elysiun…

but only blender2.37 not 2.37a …

i hope a version of blender with Py2.4 is work in process

Best regards.

Raystorm
Rico Seidel

From the Blender 2.37 Releaselogs:

his release is still compiled against Python version 2.3, for the
next we should be with 2.4. If you need a version compiled against
2.4, please check or ask at the testing builds forum of blender.org,
there were talks about having those available about a week after
official release.

1- Blender doesnt require a python install unless your using python specific imports. e.g. if all your using is ‘import Blender’ you dont need a python install at all.

2- Next release should be built against python 2.4. Python is statically linked against a library and the current build is linked against the python 2.3 library. There are no builds that i know of that are built against 2.4 unless there is a test build somewhere.

3 - python 2.4 has been around for some time now but it requires a major effort on the part of all of blenders platform managers to rebuild all the releases against a new version of python - which is the reason for the delay.

  1. import site failed is output by the sys module from the static python library. The static library is attempting to find your install using the sys module and if it can’t find it this is the standard output.