2.4 bone key framing problem, need help.

When I key frame in a bone rotation, then change to another frame for a new position, I can not rotate the selected bone (The same one)

I noticed that after the bone was keyed in, it turns a solid light blue color and I don’t know what this means.

Puzzled,

any ideas as to what is goin on?

http://s01.picshome.com/187/char_rig001.jpg

Possibly a dumb question but can you rotate it before you keyframe it?

I guess you’ve seen this page:

http://www.blender3d.org/cms/Armature_draw_modes.629.0.html

Which outlines the drawtypes and colours for the new bone system. It doesn’t explain much except to say blue means action works on bone.

Yep. This is because you already keyed it. So if you move it, an change one frame, it will discard the move you just did because it will follow the action.
The best you can do is going in action windows and delete the key at the frame you try to move your bone.

Andy D & Gabio

Yes, I can position it before the fist time I Key it, but after that , no matter what frame I go to, it will not move.

The bone is stuck in the first key framed position.

[edit] When I keyframe it in another frame it’s still stuck in the same position as the first keyframe so I tried manipulating the IPOand it will move. I just can’t grab and move the bone in pose mode.

After I key it the first time the bone turns a solid light blue color vs the outlined color.

If I delete the action, the solid color is removed and i can once again move the bone?

before keying
http://s01.picshome.com/187/char_rig003.jpg
after keying

http://s01.picshome.com/187/char_rig005.jpg

I just tried and it worked fine. Rotated, keyed (turned blue), moved forward to frame 11, rotated, keyed.

The only thing I can see from your screenshot is that this is Action.001. There must be another action (Action) - what bone does it affect?

Just the bone I’m working on.

I’m just thinking out loud here because I’m trying to come to grips with armatures and actions too so sorry if I’m not much help (I’m sure Gabiio will sort us out :slight_smile: )

I thought the second action channel might be restraining the bone but I just did another test and it doesn’t seem to work that way, each action works independently.

When you say you “can’t rotate” the bone, do you mean that when you try to rotate it, it just won’t move at all or that it keeps going back after you rotate it?

The blue color means nothing more than it has been Keyed.

Can you upload the file or send it to me ([email protected])?

%<

Well this is really weird. I was getting ready to send you the rig and made a few changes to the armature, tested it one more time and the problem is gone. . .

Anyway, Thanks for your help.

I’m curious though, have any of you completed a rig yet with 2.4Alpha.

I like the way it works. I’m doing IK for the legs and FK for the torso and arms head and hands…

I added an IK Solver for the heal, a “track to bone” for the thigh, located in front of the rig knee. When I move the heal solver the rest of the rig responds nicely and I get a nice walking motion from it.

The torso swings left and right a bit too much but I’m still experimenting and it looks promising. The new animating system seems a lot more intuitive and easier.

Have you seen any 2.4 rigging tutorials anywhere?

aaaaaaaaaaaaaaagggggggggghhhhhhhhhhh!

It happen again!

I will send your the blend file.

Here’s a avi screen shot of the problem

1.7 meg file, mpeg 4

http://gallery.mudpuddle.co.nz/albums/Room335/2_4_RIG_PROBLEM_1.avi

Well, of course, it works flawlessly for me! I’ll keep playing with it though.

When I keyframe it in another frame it’s still stuck in the same position as the first keyframe

Can you remember which of the Actions you were using when that happened?

%<

I was using auto keyframe. thir first time. Then I tried set the position maually I-key, Loc

No, I mean you have 8 actions in the Action menu. Which of those were you Keying, or were you Keyig number 9?

%<

I thought I deleted all of those. (Shift F-4, select action , select actions to delete, press F key, save file, exit blender, restart blender, open blend file)

I must have deleted them after I sent you the file. I don’t have any actions saved in the file so “Action” is the first and only one I have at this point.

I just loaded the most recent CVS and it seems to have taken care of the problem, for now…

Thanks again for your help

Well I’m using Alpha2 from 11/4 (if that’s any consolation) and I tried on and off for at least 5 hours (make that 3 without the distractions) and it all worked flawlessly.

%<

Wow, 5 hour. I apprecioate your help.

One of those bizarre things that happens, I guess. I haven’t had any problems so far with the CVS version so I’ll stick to that until an optimized version comes out.

Have you seen any rigging tutorials on the new system? I’m looking for ideas.

Gabio is busy. I have no experience outside of Blender so (after him showing what Action Constraints can do) I’m just as eager to see it all.

%<

I have the same problem described by Room335. If anyone can look at my .blend and tell me how to fix it, that would be great. You will notice in pose mode that one of the leg bones is blue (ie, it has a keyframe). If you try to grab or rotate it, it snaps right back to where it was. If you edit the IPO curve directly, it can be moved. Why, oh why???

http://www.vanshaarproductions.com/blender/Robot-3.blend

Thanks in advance for your help.