2.40 bug? Image wont load in UV/Image Editor

Hello all,

I am trying to load a picture onto the UV/Image Editor, it works sometimes, but most of the time the image just wont load at all!.. tested with many images…

Anyone can tell me what am I doing wrong?.. or is this a bug in 2.40?

To see the error i am talking about:


You can see 2 separate view at the bottom, on the uv/image editor theres no image on the background, but i actually can see mapped onto the surface under textured mode…

why why?

I have no problems with it. perhaps some of the images have the wrong fileformat?

The weird thing is, I managed to load the same image 5 minutes earlier on the right side view, and when I tried to load it again no the left side view, it just doesnt?..

Heres another screenshot,

I find it weird that I actually can see the jpgs if i click on the arrow drop down… but those jpgs just wont load at all!.. and if I am not wrong, the drop down should be dis[played with the current selected image…

the blueprint is 600K jpg file… but anyway I tried on a lot other files all not working…

whatever I try, I cannot reproduce any error equal to yours. perhaps it maybe a gfx-card problem (opengl viewports) or such a thing?

Thanks FastEddy,

I too am baffled on this, cant understand this weird behaviour…

Any other Blenderheads experience this b4?

I am going crazy… anyone would like to try my .blend?..

I have tried the samething on another .blend and it works ok… so something might be screwed up with that particular file?

I dunno how to share file here, but i can send it to your email address…


EDIT: Oops, your post was deleted~~

Hi Greybeard,

First, thanks for the wonderful video tuts. :smiley:

Okay, I am actually following the tutorial steps from here:

until this step:

When I click on the image i want, the image gets listed under the dropdown box on the right handside, but it doesnt show as the background at the uv/image editor window!

I hope I am clear… Have been stuck here for hours…

Yes, I deleted because I mis-read the post. I have never seen such a thing. Two suggestions to try – change the format of the images to tga or png – Import the scene into a new file.


i’ve had this problem also, and i don’t know why. my images are in a variety of formats to boot (bmp, jpg, tga). I’ve just been reopening my blends to fix the problem since i figured my computer was the issue.

I re-do all the uv-mapping from start, and this time I am more careful when selecting the uv faces. And apparently everything works ok now…

SO I am guessing it might be due to an incorrectly selected UV face combination… I dunno… but I will be more careful in the future…

Blender 2.44, Linux (openSUSE 10.3). Photos (.jpg, .png) from a computer in window UV/Image Editor are not loaded at performance Image-> Open-> Open image. (3D window is in UV Face Select mode, all sides of mesh are selected.)
Somebody faced such problem how it to correct? Thanks.