2.40 Game engine build(docs added).

after some further testing I noticed something else a bit odd…

When I tried to activate Blender Materials on larger files, realtime lighting acted almost as if it had been disabled…Blender even crashed when trying to load one of my big Transcendent levels.

the main file I tested this on used Sun lamps however…is this the reason why realtime lighting didnt show up?

Im sure I set up the whole scene correctly too…Realtime lighting works fine with smaller objects and smaller scenes but for some reason it wasnt affecting the models when I tested this on big levels…

Think this is some issue with my computer? Is anyone else having this problem with large files?

All this stuff is some what alian to me can Blendermag start writing up on all these features as well as some tutorials.

committed the armature-fix and the rest of the changes to bf-blender cvs.
Opened up a multi-platform problem can of worms :slight_smile:

Anyhow, apart from the multi-texture/shaders, there is an experimental linux build here. just armatures/split windows I guess.

http://www.continuousphysics.com/ftp/pub/test/index.php?dir=blender/&file=blender-linux-glibc232-i386.tgz
Erwin

I’m confuse, is this going to remain seperate, is it a fork program or is this going to be put into the next build of Blender3D ?

Hey Erwin

you’re a nice guy ( I guess :slight_smile: )and your work is great, but…your link is dead

Al_capone,

the patches are already committed to CVS, the armature fix will almost certainly be in the 2.40a release. The rest will hopefully be as well - although the shader stuff might not be doable on the other platforms, so not sure what we will do on that…

LetterRip

I think this might be the correct link
http://www.continuousphysics.com/ftp/pub/test/index.php?dir=blender/&file=blender-2.40-armatures-linux-glibc232-i386.tgz

Question

In theory though :wink: the OpenGL shading laungage stuff should work on ‘all’ platforms? What is preventing these features eventually being available on OS’s other than windows?

It would be fantastic if we could create and tune these OpenGL shaders in realtime with the new material node system :o In the games industry we poor artists are at the mercy of coders precious time when it comes to shader creation.

thanks everyone for your hard work

Thank you fobsta

OOOOOOOOO my GOODNESS ! That really ROCKS!

Need to test the linux build. But Im experimenting exactly the same problem as Pooba whith the shader examples.

I get the same thing as scabootssca when I run the GLInfo blend. Is this my software (as in I need to update my drivers) or hardware (I need a new graphics card). Sorry if this is a stupid question, I dont know much about computer graphics like this. I’m using a Nvidia GeForce2MX.

you need a new graphics card

at lease a geforce 5 series???

Hey all,
Hopefully we can get this up and running on Linux.
some docs and shader tests will be up soon so we can work out whats going on with these errors.

invid:
I will look at that as soon as possible

TomorrowMan:
can you post or send me a blend with a crash happening ?

thanks all,
snailrose

Hello, its me again, me from ages ago.

I found a problem with this build; it dos’nt seem to play any sort of sound…

Otherwise brilliant. I may stick with blender this time, I could’nt find anything much better even with commercial software (they all required you to buy a commercial 3D package as well.)

BTW Can we remove the automatic shutdown on the Escape key thing?

It is running on linux now. It works nice on an NVidia 6600GT.

Download this file:
http://www.continuousphysics.com/ftp/pub/test/index.php?dir=blender/&file=blender-2.40-linux-armaturesShaders.tgz

And the sample from the Windows version:
http://www.continuousphysics.com/ftp/pub/test/index.php?dir=blender/&file=blender-2.40-GEplus.zip

Have fun,
Erwin

Too much joy!!!
Finally a “finished” working game engine version
Many thanks to all

That split-screen is IMMENSE!

Great work.

I give it 5 :Z 's :stuck_out_tongue:

hello, i have a question about multitexturing and access to a second uv set:
can we use lightmaps with this build?
-first uv set: the texture
-second uv set: the lightmap
-and blend the two

it would be awsomne :o

OSX build

No clue if anything works I cant find any test files to play with please tell me if you find some

err nev mind, errors came up… not working build yet … sorry… still trying posted an error to bf commiters if ya want to help

the testfiles are included in snailroses’ windows build:

http://www.continuousphysics.com/ftp/pub/test/index.php?dir=blender/&file=GE-build-1-4-06.zip

I have only noticed an error on the GLSL script, the position of the light doesn’t affect the model, as you can see in the seb demo, I tried to apply cell shading but the same error appears, cell shading works but it looks like I’m only using a reflection map, how can I fix it?