2.40 pre-release alpha1 / Windows

You can read the post here.

Wow, this is very good news indeed!

News page:
http://www.blender3d.org/cms/Newsitem.607+M5fb2949f2a7.0.html

I can’t download it.
It says:

550 No such Directory.

Is anyone else getting this?

Hey Python 2.4 support and a lot more. Hehehe. Sweet!

Blend on!

Kevin: just choose a different server, even if it isn’t the closest to you.

what is support more with python 2.4???

No cekuhnen, it’s Python 2.4 support and a whole lot more! I sound like a Blender commercial, hehehe.

We are stepping out of the python 2.3 zone and into the 2.4. I really don’t know what this will mean but it’s gonna be good.

  • When I apply the subsurf modifier and go into edit mode, the 3D viewport does not update real-time when movnig vertices… I have to go out of editmode and back in to see it updated.

  • The “Draw optimal” function with the subsurf modifier also doesn’t always show the optimal lines…

Does anybody else have these observations?

Why are the new Particle Features (bullet patch) and the explodemodifier not in this Pre-Release? Hope this don´t mean they wont´t be in 2.40 stable release :frowning:

  • When I apply the subsurf modifier and go into edit mode, the 3D viewport does not update real-time when movnig vertices… I have to go out of editmode and back in to see it updated.

  • The “Draw optimal” function with the subsurf modifier also doesn’t always show the optimal lines…

I don’t have these problems (W98). What are your system specs?

Why are the new Particle Features (bullet patch) and the explodemodifier not in this Pre-Release? Hope this don´t mean they wont´t be in 2.40 stable release

See the pre-release notes:
http://mediawiki.blender.org/index.php/Blender_2.4_pre-release_notes#Overview_and_release_plan

Next to the Modifier Tab you have three grouped buttons that you must press. These buttons amke the modifier active in Render, Object and Edit mode. And next to those three buttons you can press the little grey circle for “Optimal?” mode. This should get things working like normal.

i could just cry.

i am soooooo happy right now! the fluid is amazing!

great work devs!!

Wow, someone needs to get out more!

Wow, someone needs to get out more![/quote]

well, its not me!

As Blendhackers Guide to the Universe said

“Johnny Matthews has rebuilt the Mesh Subdivide tool from scratch”, and converts knife tool in piece of crap.

Can somebody figure out how to achieve old knife tool behavior in 2.4a?

Change to “inner vert” in this panel:
http://img418.imageshack.us/img418/9871/panel5js.jpg
I never understood the new behavior either, but someone might find it useful :expressionless: Thankfully, loud protests gave result and made the old behavior an option :slight_smile:

yes. that new knife cut tool almost got me to. i imagine the new ones are helpful for more straight and mechanical modeling(definetly not organic i would imagine)

i’ve been playing with the new Armature system…geez! i’ve never messed with armatures more than once or twice. I already feel like i could animate within an hour or two of reading and such. They are so easy to use !!!

great job blender coders.

Clip start on the camera still seems to be limited to 0.1 minimum. If you make a cube, select one face, subdivide, select one of those faces and so on and zooming in each time, you quickly reach a limit of about 6 subdivisions before the camera starts obscuring your view. It makes editing polys on a detailed level very difficult.

Why, if you can set render cameras to a minimum clip start of 0, is the render camera stuck at 0.1? Even if the limit was 0.001 or something.

Hoorey!

Thanks for advice Bellorum, and thanks to Johnny Matthews for survived old behavior.