2.43 Rc3?

Um, am I reading this page correctly? I decided to finally break down and dl RC 2 instead of waiting for the full release, but the download page has something called RC3. I was under the impression that RC2 was the last pre-release candidate. link

I can’t open the link you posted, but on this page …

There is in fact a 2.43rc3 with yesterday’s date on it :slight_smile:

Just windows and “darwin” (whatever that is) so far.


The Darwin award is meant for people who died in an unbelievably stupid way…

…and the Mac OS X kernel is called Darwin as well, so I guess that’s what the Darwin version’s for :wink:

(I’m not saying OS X is stupid, by the way :p)

Though on the Blender website, it says in news that 2.43 rc3 has been released, even though the date is the same as the rc2 release.

Also, this page http://www.blender3d.org/cms/Changes_since_2_42.771.0.html , has this text:

Feb 4 update
A third release candidate is being made now. Release has to wait for the website migration/update, which should be done around Feb 10.

Which, personally, I read as “It’s done, but we can’t kick it out the door officialy yet,” more or less, and so I went and downloaded it ^_^.

I was wondering if this is a bug or perhaps there’s another option to enable it…

When you use the Transform Manipulators, you can choose your Transform Orientation, View, Global, etc… These all work just fine, but ONLY if you use those Transform Manipulator widgets. The Transform Orientation does not work if you use the hotkeys(which i only use). So like if I type s x, when i’m in View mode, it should transform based on my screen orientation, not global. However it only transforms in global space…this is pretty annoying as I’d like it to set it to transform in View, or in another orientation.

Edit: Nevermind, I figured it out! Or I found it rather…You press S X X to scale in local view, etc… yay I’m happy now :slight_smile:

I only use hot keys as well, I think you can only transform in global and local systems.

I noticed in this RC that in Sculpt mode, the widget is enabled by default. This is confusing to me, since the widget is not used in sculpt mode, so it causes any brush application close to the widget to move the mesh object away from center… I could set default to ‘off’ on the widget, but I use it for so many other purposes in other modes. Hmmm.


Sculpting with textures doesn’t work for me. The “Drag” option makes the mesh disappear, and the “Tile” option crashes Blender.

Could Somebody confirm this?

I believe I have the same issue, but I have found that clicking ‘3d’ enables it to be used as a brush on the mesh pretty well - I don’t really understand what the drag and tile are supposed to do, but maybe this will help. Big Props to Nicholas on this - very nice sculpting possible now - I just need to learn to work around the UV painting, I seem to have problems with unwrapping on the wrong level and losing my map image. Somebody said you have to drop back to the first res level to unwrap, and I keep forgetting to.:o


intel osx file is corupt does not open

Yes, happens with me also (since RC2 actually, in RC1 it works ok).
I believe this bug has been reported already…i just hope it gets fixed.


Bugs? Or not bugs?

  1. When you have an armature with more than 4 bones, In the buttons window(f9), it only shows 4 bones in RC3. It shows 5 bones in Blender version 2.41-2.42RC2. In Blender 2.37 it shows ALL the bones.

  2. When you try to grow/shrink a selection by pressing ctrl+num+ and num-, once it has everything in the object selected, you cannot shrink the selection.

The bone display limit is to keep the buttons window from expanding to an obscene size. Grow-shrink selection works on borders. It expands or retreats the border. When everything is selected, there is no border, so it has nothing to work from.

I wouldn’t mind waiting if it means a new release that’s more stable and bug free then usual (you may thank the decision to prolong the bug fixing period later on)