2.45 segfault with game engine

Hey all,

Wasn’t sure where to drop this, but thought doing so in this forum might be least objectionable. If any mod thinks this should be moved, please do :slight_smile:

Anyway, I’m running 64-bit opensuse 10.3
On both the 64 bit blender (2.45) and the 32 bit blender (2.45) [I haven’t tried other releases yet] when I press ‘p’ I get a segfault immediately.

[edit] I’ve tried the static versions, but can’t get them to work at all yet [/edit]


Detected GL_ARB_texture_env_combine
Detected GL_ARB_texture_cube_map
Enabled GL_ARB_multitexture
Enabled GL_ARB_shader_objects
Enabled GL_ARB_vertex_shader
Detected GL_ARB_fragment_shader
Enabled GL_ARB_vertex_program
Detected GL_ARB_depth_texture
Detected GL_EXT_separate_specular_color
GL_VERSION: 2.1 (2.1.1 NVIDIA 100.14.19)
open /dev/[sound/]dsp: Device or resource busy
open /dev/[sound/]dsp: Device or resource busy
(no debugging symbols found)
(no debugging symbols found)
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x2b9feb8a3820 (LWP 4734)]
0x0000000000000004 in ?? ()
(gdb) backtrace
#0  0x0000000000000004 in ?? ()
#1  0x0000000000a510ac in BL_Texture::DisableAllTextures ()
#2  0x0000000000a63d26 in KX_BlenderMaterial::setTexData ()
#3  0x0000000000a64026 in KX_BlenderMaterial::ActivateMat ()
#4  0x0000000000a640e0 in KX_BlenderMaterial::Activate ()
#5  0x0000000000aa19fa in RAS_OpenGLRasterizer::SetMaterial ()
#6  0x0000000000a9fa70 in RAS_MaterialBucket::ActivateMaterial ()
#7  0x0000000000aa0401 in RAS_MaterialBucket::Render ()
#8  0x0000000000a9f39a in RAS_BucketManager::Renderbuckets ()
#9  0x0000000000a7834a in KX_KetsjiEngine::RenderFrame ()
#10 0x0000000000a787f5 in KX_KetsjiEngine::Render ()
#11 0x0000000000a2a355 in StartKetsjiShell ()
#12 0x000000000058ddb4 in start_game ()
#13 0x000000000058ee75 in ?? ()
#14 0x00000000005d7eec in screenmain ()
#15 0x0000000000531eed in main ()

I know this might be better over at blender.org, but wondered if anyone knew of this happening before, or if it’s a common problem (search revealed nothing, but that might just be me).

Thanks for any help :slight_smile: