2.48 BGE Issue

I’ve just begun playing with BGE a bit, and have been refering to Blender noob to pro tutorials: http://en.wikibooks.org/wiki/Blender_3D:_Noob_to_Pro/An_aMAZEing_game_engine_tutorial

However, I’ve noticed that in Blender 2.48, you can’t make an object Dynamic AND have a rigid body. The tutorial says I need both… Now, I thought perhaps I only needed one, so I tried the game out, and when I press forward, left or right, my “avatar” flies out of my little hallway into the blueness outside.

when it’s falling, if I hold left or right, it spins around very fast. Does anyone know what I can do? (I set all the controll settings right I believe)

Dude, when you make an object a rigid object it automaticly makes it dynamic, too.

Yeh, these settings changed recently. Basically rigid body is a body which can rotate etc, so therefore it is dynamic (not static)

Setting it to just dynamic means it can move, but not rotate.

Try setting it to rigid body, see if that works.

Well it’s set to rigid body, but the cone (my avatar) still rotates way too fast. Here’s my Logic settings: http://i259.photobucket.com/albums/hh313/UruJustin/Logic.jpg

Have you tried turning down the rotation speeds? Just tweak them until they work how you want.
Perhaps increasing the rotation dampening will also help.

wowow, lower done every acuator! The movement ones should be Dloc 0.10 or -0.10 or anything below one. and the DRots should be, 0.05 or -0.05, not 5.00 thats too much.

Dloc and Drot basically move/rotate your object that distance EVERY LOGIC TIC (aka 60 times/second by default). When you put in 10 for dLoc, every logic tic your object is moving 10 blender units… or 600 blender units per second. With dRot, it’s a bit different… but think of 1.8 as 90 degrees per logic tic.

You really shouldn’t be using either of those for movement though. Look into the servo control actuator.