2.48 not downwards compatible?


I’ve made a animation in 2.46
Installed 2.48
adjusted the animation
Try to reopen it in 2.46 or 2.47 and Blender crashes.

Because of the farm i’m using i need to go back to 2.46. How can i do that…

I use some UV painting, and some movies textured on planes.

Any help is really appreciated.

Thanx, Twan

The same is happening in here

It would be helpful to have more details. In this case, a file would also be good.


I don’t know the cause, but I would try taking the movies off from the planes (perhaps 2.48 can read a format that 2.46 can’t).

As a preventative, I would really suggest using a tool like git http://git.or.cz/ in the future. This way you have a copy of the files you are using saved so you can always go back if there is a problem. I’ve started using it for all important personal files & all work (it’s already saved me several times).

Did you save over the original?

If not, you can just go back to the original file and edit it there.

If you did save over the original…

It’s standard practice to make difference versions of a file. Especially when you upgrade the program. One tends to get into the habit of doing this while working with Blender SVN.

Try to use Append function.

Thanx for all the suggestions and yes i’ve made a mistake in not backing up the file. Although i always do but not with a new Blender version.

I tried to reproduce the problem but with or without a movie and/or UV mapping i cant get back to the problem.

I tried the append option and when appending the objects Blender crashes. There are over 200 objects as lamps, cruves, planes etc


It seems like the only options at this point are to check the directory for the file you are using named .blend1.

Like animation.blend1

This file works as a small back up. Also in the temporary directory you might find an older version of the file you are using.

If you can’t find it still, there is always the possibility of updating the farm, or waiting for it to be updated.

When appending any objects, or are there specific ones that crash it?

Blender makes every effort to be backwards compatible, which you have observed. You can run 2.48 to open a 2.46 file. But nothing is ever really forwards compatible, because the file contains data about features that were not possibly even conceived. A 2.48 file contains info about X Y and Z structured to be processed a certain way, whereas a 2.46 file contains x and Y, where x and X are information structures about the same thing, bu X contains much more.

If you are using 2.48, stick with it and don’t look back, you can never go back. Just upgrade everything…its free.

In my enthousiasm i always download and install the newest blender version and never thought of the fact that it would be possible not to be backwards compatilbe. I never knew i could make such complicated animation.

@Ianc: I have about 99 planes and i think that there somewhere something is wrong. So i’m pretty sure its no curve or cube nor the lamps. But its to much to find that out.

I had some mirroring and raytracing in the animation which why it took about 10-15 min a frame on my Macpro!!! I have 4500 frames so thats why i bought time on a renderfarm. But i followed a tutorial to bake some textures and adjusted some other things bringing down the rendertime to 30 seconds!! Thats about 26 hours on the Mac

So I learned a lot, am not completly satisfied but i dont have to make a new animation for now.

Thanx you all

Good work, keep it up. ------ Arron (Hot Kicks).

You could create a bug report for it and add the .blend if it is possible for you to share it. Anyway, what’s specifically the reason to use one of the older versions?


@Jesterking: I kept on getting dead frames on the external farm that I was rendering on and this farm was working with 2.46. So I found out that on every frame the the .blend was opened it crashed. Trying to open the .blend file saved with 2.48 with 2.46 did crash Blender here at home. As said before: Simple cubes moving from left to right with UV mapping and a movie texture saved with 2.48 could be openend with 2.46 with no problem.

I dont have experience with the bug-report thing but if it is helpful I will submit one.


Submitting is simple, register with http://projects.blender.org and go to the bug tracker after you’re logged in. Then choose to submit new. Read the instructions to ensure you have a proper bug report, then report :slight_smile:

Of course it is helpful. Without a bug report, you are in danger of this not getting fixed, if it can be fixed. Not sending bug reports = shooting yourself in the foot.

/Nathan :ba: