2.49 bge anomolous behavior


I’m still new at this game engine stuff. I’m working on my ‘Liberator’ game in this thread.

First, I zipped the blend file before uploading. When people, including myself, downloaded the zip file, all of the logic brick connections were gone. I assume it was a corrupted zip file. That’s fine but…when I ran the game with the broken connections, it still worked on my computer(?)

Now, I’ve uploaded several versions of my Blend file, all uncompressed. It seems, though, that no-one but me can run it! :eek::spin::mad:

I’m running Blender 2.49b, and Python 2.62. I’ve built the game around a few logic bricks running internal Python scripts. I’ve made sure I’m not using any deprecated code. I get absolutely no errors on my PC. So why won’t it work when people try to run it? Any ideas??

Here’s a linky to the blend: Liberator

I got it to work. I just needed to download the scores.txt file and plug in a joystick.
If no joystick is plugged in I get an error saying

“Python script error form controller “active#CONTR#2”:
Traceback (most recent call last):
File “CCLiberatorControl”, line 97, in <module>
IndexError: list index out of range”

Other then that this game works very well, I really enjoy playing it.
Well done! :slight_smile:

Thank you thank you!

Yea, umm, I forgot I have multiple game controllers plugged in, so when I checked for errors in the joystick sensors (unplugged), I wasn’t getting any.

I have a lot of error handling script to write now before I can upload another version.

I appreciate your help!