2.49 Problems. Post here

I have a problem with 2.49. Didn’t see any threads up for problems so I made one.

So, I can’t seem to set object orientation now. object.setOrientation(ori) works but object.orientation = ori doesn’t, the object just goes invisible.

blender-2.49RC1-windows.exe - all works, or low FPS, very low with mirror texture animate nods etc. For exemple my demo scene in :

  1. blender-2.49RC1-windows.exe - 2 FPS
  2. Blender 2.48.2 [19344] - 2.5-3 FPS
  3. SVN 17735(videotexture-mirrortexture) 11 FPS

@andrew-101 orientation bug is fixed in svn (will be in rc2)
@Demander, post a blend and I’ll run through sysprof on linux to see where the bottlenecks are.

The view port flashes when selecting any point on Intel card , when it is set to view only not wireframe (the cube in the edit mode near line select).

This bug it is not present in Blender 2.5 , i hope this will not be in the final 2.5 either.

The bug it is present in 2.49 and 2.48…

Renders blender 3d unusable.

System specs : Intel Core 2 Santa rosa platform 1,6 ghz , 4 gb ram, Windows Vista Business

Tested the 2.49rc on 32bit linux and its REALLY SLOW.
But this looks like a build problem, since on my own build I can get 90+ fps, a debug build with no optimizations 16fps, 2.49rc 3.5fps.

Whats the new ‘outside’ thing in the profiler?

  1. Controlling the IPO trough python gives unexpected results.( see attached blend , type a positive or negative value and press Ctrl several times, sometime it’ll works and something not)
  2. in the same blend, if I pack the blend, the bitmap font stop working except if I go to the UV and click on Image-> reload.

Attachments

IPObug.blend (451 KB)

If you mean ‘outside’, wasn’t that always there, at least I don’t remember not seeing it before 2.48?

Ok yea, I see why I thought it was new. Its in ms then and % in brackets.

2.49rc1 crashes from a segmentation fault as soon as I start the game engine.
no ifs, no buts, it just crashes. I’ll try to get it to give me a core dump, which I will then upload.
my system is:
ubuntu 8.10 gnome - havn’t replaced any librarys except for my graphics driver replaced the opengl libs (this is normal)
512 mbs ddr ram
1.5ghz intel 32bit p4 - can post /proc/cpuinfo if neccesary
nvidia geforce 2 mx 400 with official (nvidia, not nv) driver
i thinks that’s everything, “ubuntu 8.10” covers a lot
oh, and i downloaded “blender-2.49-RC1-linux-glibc236-py25-i386-static.tar.bz2”

@blendmaster1024, did you try this?
http://blenderartists.org/forum/showthread.php?t=154469

I posted a bug report about this already here, but collision sensors / detection don’t seem to work for parented objects. Before anyone says “turn compound on in the parent object” please read the bug report closely. :slight_smile: This is mainly to do with sensors not working, but also touches on that it’s strange for dynamic / static child objects to act like they’re set to “no collisions”.

Hello,
Ended up using Ashsid’s pluggin recently to show some work as I was having problems with Webcam on what was then the latest SVN. So I have just checked on the RC1.

using:
GameLogic.vidSrc = VideoTexture.VideoFFmpeg(‘cam’, 0, 1, 640, 480)

I only seem to be able to get the first webcam (ie. 0) to work. This was a problem for me as I was using a Canon camcorder as a video source… Worked fine in Ashsid’s pluggin with cam value set to 1, but not on VideoTexture in RC1. Have also tried it with a second web cam and get the same result.

After a little more research I have found:
On my laptop (winXPpro, Nvidia 8600m GT) only cam = 0 works. set to any other value you just get black.

On my desktop PC (WinXP, Nvidia 8600GT), a ‘choose device’ dialoge pops up with the available choices in it, and then will only show device 0 anyway.

This is a problem for me as the camcorder output looks fantastic and I don’t want to loose it (I don’t know if Ashsid is updating his plugin for 2.49).

ED 3rd May: Got a reply from posting a bug report that this is due to problems in the FFMpeg code, not blender, and will be fixed when they fix it.

I don’t know if its a “problem”, but there’s no sound in the “video texture” demo?
One can have OGG as “video” but not as “sound”?

I’m pretty sure VideoTexture has no sound by design. Ashsid’s pluggin does

i downloaded the dynamically linked one, and it had no problems with crashing as the GE
starts.i think that the problem with sdl is not there is all versions,
but that it is with whatever you statically linked the static one with.

In linux (ubuntu 9.04), if I open my old files the OpenGLshading just shows as if emit is set to full, and textures are off. When I press p, it gives me a segmentation fault. Same setup works on RC1 for windows without problems though, I’m running the 32 bit version both on windows and linux. (static version, don’t really know the difference so maybe that’s the problem)

I can’t seem to get spec maps or stencil maps to work in the BGE. They show up in the view port realtime but they do not show up in the BGE. I’m running 2.49 RC1

Do the same file work in 2.48 (are you sure it’s RC1 specific?)?

I’ve tried the same exact blend file in 2.48 and it works just as its supposed to. The problem seems to be in 2.49RC1. :frowning: