2.5.4 - No export plugins work?

I know it’s an experimental release, but none of the export plug-ins work and I need them to. Every time I try to use one, it comes up with its own little set of errors that mean it won’t do it. For example, with 3ds exporter, it claims that the global identifier “os” isn’t defined :\

I have tried to add “import os” to the 3ds export script. No luck.

Have you tried a recent build from http://www.graphicall.org. Otherwise stick with the stable 2.49b version for critical work.

Nope, it seems like this one particular model doesn’t work.

I can export a cube to 3ds, but not this thing I’m trying to export. It has five materials, uses a total of three textures and all modifiers have been applied.

It seems to be a material issue:


Using 31784 I was able to export a .3ds and .dae file, the simple cube and re-import them using poser. Those two formats work. OBJ is broken and produces no output.

I mentioned this in other threads,

The obj export does work “just retested” as long as you use layer 1.
Go figure.

export_3ds.py should be fixed in trunk even without a bug report…

Alright, it turns out I was adding import os to the wrong file - I was adding it to the export script for Blender 2.49. So the result is successful - by adding import os to the right file (export_3ds.py) I fixed this problem.

Thank you for your time.