2.5 ambient occlusion

hi, im trying to add ambient occlusion to my animation but ao seems to be fairly different then in 2.49. i have tried to get this to work right with and without lights but neither way seems to work, the ao seems to just turn everything the ambient colour, ive tried lowering the value of the ao, increase and decrease the sample, change it from multiply to add. setting up ao just seems to be much different now and i havent been able to figure out how to get it working.

this is how it currently renders:

if anyone can tell me what i may be doing wrong that would be great thanks

If you have it set to “Add”, try lowering the value to 0.5 or something similar. Sometimes the default AO settings don’t always work.

If you have lights in your scene, it may be better to set it to “Multiply” instead. The “Multiply” blending mode favors black, adding shadows and increasing the contrast in the scene. “Add” is a good way to get an even lighting distribution, especially with very few or no lamps at all, but if you’re looking to darken your shadows, “Multiply” is the way to go.

Good luck!

thank you very much for your reply, after a bunch of tweaking of those options with the values you recommended it didnt seem to make a difference, everything was still being rendered in the ambient colour, after searching around for something else i was missing i found that i didnt have render shadows on which now i know is pretty important for ao. then i went back to the options you suggested and add didnt change but i tried multiply and after some more tweaking i got that to work, i was hoping to use add so i wouldnt need to use lights but using 8 or so lights with only half energy seems to make it work well so thank you.

Typically it’s the Environment Lighting setting that makes the transition from 2.49b confusing. Assuming you have lights in your scene, disable it. I also recommend multiplying your AO. This is my default setup with a four point light setup (1 key, 2 fill and 1 rim lights).