2.5 baking

Wondering if anyone else has had this. It has happened before and I am not sure why. Sometimes it works other times what it does is gives an error message saying it can’t find an image or object to bake. Wondering what I am missing in this case?

I have tried to refresh the image mapped to the UV in edit mode several times. Even mapped it as a texture. Nothing works.

Any ideas?

I’m not sure if it’s the same thing, but I’ve had inconsistent bakes as well. In other words, I bake, and then immediately re-bake and get different results. The solution was close Blender and re-open it and the problem would resolve itself (until a later time).

Beyond that the other problems I’ve had was needed 2 separate UV’s (even if identically mapped) for 2 different images: http://blenderartists.org/forum/showthread.php?t=204020&highlight=

Hopefully one of those helps resolve the issue.

I have had the inconsistent thing. Actually for the better. Like the first time it is horrible and the second time it is correct and I did not change anything.

Now, for multiple UVs do you mean if you have more than one texture in the scene? I am not sure I followed that. But I only have one UV map and one image texture in the scene. Are you saying I should use 2 UV maps anyway?

Again, I’m not certain it is the same thing, or that I know, but hoping. In short, “yes” (and I’ll try to explain better).

You have a source texture (procedural or UV mapped), if procedural, still give it a UV for kicks. Next, create a second UV for the destination image and in the UV image editor get it setup so it’s over your destination image. So the idea is you have a separate image source (procedural or texture) and a separate source UV for it, then you also have a destination image with a destination UV.

If that doesn’t help, I’d be happy to help further, but would need to understand a few more details (so I can try to recreate). Is your source procedural or photo? How many texture channels (and how are they mapped)? Any modifiers on the object? (the bevel for example seems to really horque the bake, I had to disable it in order to bake, maybe check on those too).

Not that I think it matters (but just exploring to troubleshoot), did you UV smart project by chance? (I’ve also had some oddities with this regarding the bake, though I think it may have been me at the time - bevel modifier).

I’ve given up baking in 2.5. For some reason or another, it’s much slower than 2.49b, and that’s when it decides to work at all. I have taken to just opening my scenes in 2.49b, baking, saving the tex, and then re-opening them in 2.5.

I’ve almost come to the same resolve for UV editing with textured mode on in the 3D view port… it’s painfully slow.

I recognize that error message, it happened to me on two occasions. The first one was when I selected the objects through the Outliner (apparently, it’s not the same thing as selecting through the viewport). The other was when I didn’t switch to Edit mode after selecting the second object.

You should try this:

-Select the objects through the viewport.
-If the objects are contained within different layers, make sure they’re visible.
-After selecting the second object, switch to Edit mode.
-Select the proper image in the UV editor.
-Hit Bake.

may be you should report it has a bug
dev’s will have a look and if anything has to be corrected they will take care of this problem
and let us know if it is corrected !

happy 2.5


Thanks for the help. Sorry I did not give more specifics. I should have said I tried different baking modes to the same effect. Basically I was trying to bake normals and I also tried AO as well as full render, and I think maybe textures.(I only did this just to see what would happen) But the main thing I was trying to do was to bake normals. I had an object with Armature, Multires and Subsurf mods in a stack. I thought maybe the mods in the stack so I got rid of all but the Multires since I needed that. And it still did not bake. That was when I tried different things to see if something else would bake also.

I tried it in edit mode also. Tried all of the little “refresh” tricks that seem to work in other cases.

But let me take all of the ideas here and see if I can be a bit more scientific and try to recreate something predictable. Because just the other day I baked the same set up successfully. I’ll take another look at that file and see what was different.

The other thing that gave me the error message was if the image was only created but not saved yet. Unfortunately that did not work this time either.

I also tried to close and restart even downloaded a different build from graphical.

So anyway, I’ll give it another go and report back here.

EDIT: Forgot to add. The UV Map was unwrapped with a seam not the smart option. The mesh is a simple cylinder as a dress.

Thanks for the replies!

OK Update:

I am at a complete loss here. I have no idea what it was. It is not modifiers in the stack or anything. I simply appended the objects into another scene and baking is working. I don’t know what triggered it in the other scene.

Maybe it is a bug then, let me explain. If I have a blend file with an object in it, textured rust, I save, close it, etc. Later on I create a new blend and append it, give it a new texture (delete the previous material completely in fact, I also failed if I delete the material in the source blend before the append also), lets say metal now and then export it as OBJ (for external rendering), I the (mtl) texture will still import as the original rust. I went through the datablocks and tracked things down, but things still didn’t work.

My point being, is I have seen whatever previous textures I had get “snagged” in as I have appended. I guess I completely forgot as by the time I got to the external renderer I would redo the texture there and has become habit now.

How complex are the UVs? I’m asking because if it was easy enough you could try to export OBJ (no materials), and import your scene, re-setup and re-bake and see if it resolves. That would confirmed a “snagged” texture. I also have a very specific project that this killed me on (and I also had baking problems), I’ll go look at it again.

Yeah, that fails.

Steps to reproduce:
1.) Create a new cube, unwrap it.
2.) Create a texture-> Test Grid -> save to file.
3.) Setup material with the test grid texture.
4.) Save the Blend -> Source.blend

5.) Edit the texture (test grid) file with GIMP, colorize it or something.
6.) Create a new file (CTRL+N)
7.) Append the cube from Source.blend
8.) Delete the material.
9.) Create a new material, assign the colorized test grid (UV).
Render, everything looks good.
10) Export as a OBJ to a new directory, check copy images
The output will copy the original test grid, not the colorized one.

So whatever value the export script reads to determine what image to copy must be incorrect in the datablock.

EDIT: I logged the above to the tracker. Still not guaranteed it fixes your exact issue … yet.

I am wondering in all of that, if you, again, assigned the new painted image to the UV map in Edit Mode before saving. As far as my understanding of the way it works anyway is that the image gets linked to the UV map for painting. This should be completely separate from the mapping. So you should be able to render a different image than has been assigned to the UV map for Textured Face and Multi Textured display modes. GSL will display the mapped (Image, Mapping, Image Influence) result. The bug may be related to these two getting confused or conflicting somehow.

My situation had nothing to do with appending other than to fix the problem. And this is just testing I am doing. TD work for a project I am working on. I am just trying to find what is working and not and come up with a reasonable workflow for something. Sculpting is potentially part of of it. But unfortunately baking - even working - is not working well enough. And I am scupting in 2.5. That does not go back to 2.49, because I tried it already.

I am trying various different solutions for cloth effects. Some with no cloth only sculpting, others with part cloth and sculpting and so on. Just trying different combinations of effects. So for the cloth effects with sculpting, I can not use the multires modifier because it forces it under the cloth mod. So in this case all I can do is bake and apply as a displacement modifier on top of the baked cloth and sub surf.

The file in question just, I don’t know what I did or what thing I was doing, adding or whatever but it would not bake. But a fresh scene with my cloth objects appended “worked”, though the baking was horrible even though I had it working perfectly a few days ago. Forgot what build that was.

Tricky. I don’t know, was hoping I could help, but you’ve got something sticky. I’m sorry. With luck somebody else will have some insight.

Well it was a help, believe me. Better to at least have some feedback and know if nothing else that it was beyond what other people have experienced and that led me to just open another file instead. Hope I don’t run into it again though. But if I do maybe I’ll note what I recently added or did.

Could you perhaps upload the .blend-file you were having problems with? Just to check if the problem occurs on our systems as well.

OK, I removed everything from this file except the dress object. You’ll have to create a new image and give it a whirl. Multires won’t matter, it’ll either bake or it won’t.


Won’tBake.blend (533 KB)

I got some good news for you: The baking worked like a charm! Though to be honest, I only tried baking the Normals. But nevertheless, it worked well.


This is how did it:

  1. Duplicated the dress and sculpted a Hi-Res version.
  2. Created a new image (1024x1024) in the UV-editor.
  3. Set the parameters according to the screenshot above
  4. Selected the two dresses in the correct order (Hi-Res first, Lo-Res second).
  5. Baked!

Again, both object must be visible in the viewport in order for the normal-baking to work.

Here’s the modified .blend-file:


P.S. Sorry for the crappy sculpting/lightning. =)

That’s good to know. It does not explain why the dress loaded up into a fresh blend file bakes (with no steps like above). And you should not have to do that for baking to work period. But it is good to know a work around on a corrupted file. So I wonder what the actual bug is?

Thanks for taking the time!

Well, in order to bake normals, the above steps are in fact necessary. However, that doesn’t apply to the other baking options (i.e Shadows, Textures, Ambient Occlusion), where you just need your regular mesh. I did a Full Render-bake using your file and it worked very well, so I suppose there shouldn’t be any more problems. =)