2.5 Beta will not run :[

So I’ve had an issue with 2.5 from the start. So far I haven’t found anyone with the same issue. I was hoping that once they came out with Beta, things would start working, but they don’t.

Basically blender will start, but is so slow/unresponsive that I can do nothing (except maybe pan around a little, and that only between periods of frozenness). Just sitting there, the program churns away with 50% of my CPU power.

My only guess is that something that’s supposed to happening in the GPU is happening on the CPU. But I don’t really know enough about computers to tell.

So I’m super-bummed. Does anybody have any suggestions?

Here are the specs on my gizmo:


Manufacturer Dell Inc.
Model MM061
Total amount of system memory 2.00 GB RAM
System type 32-bit operating system
Number of processor cores 2
64-bit capable Yes


Total size of hard disk(s) 343 GB
Disk partition (C:) 26 GB Free (100 GB Total)
Disk partition (D:) 6 GB Free (10 GB Total)
Media drive (E:) CD/DVD
Disk partition (G:) 162 GB Free (233 GB Total)


Display adapter type ATI Mobility Radeon X1400
Total available graphics memory 895 MB
Dedicated graphics memory 128 MB
Dedicated system memory 0 MB
Shared system memory 767 MB
Display adapter driver version 8.360.0.0
Primary monitor resolution 1280x800
DirectX version DirectX 9.0 or better


Network Adapter Broadcom 440x 10/100 Integrated Controller
Network Adapter Microsoft Tun Miniport Adapter
Network Adapter Dell Wireless 1390 WLAN Mini-Card

Thanks for paying attention :smiley:

-blue :[

…and plz ignore the involuntary random smiley’s in the storage department :smiley:

it’s a dell? I’ve never heard anything good about dell, in fact I was just reading about them :no:

however, have you tried updating the graphics driver?
sometimes that can solve huge amounts of problems, especially with ATI cards.

check if any sound engine is turned on by default and turn it off, see if that fixes the processor drain

Yes, like ZanQdo wrote, try to change sound system in UserPreferences to other than OpenAL or just None.
On my Ubuntu it uses 50% of CPU with no reson. OpenAL is default sound system in B2.5.
Did you enable any add-on scripts?

Try changing the window draw method in the system tab of user preferences to something else.

@ spaceug

sounded like a good suggestion so I updated everything there was to update and then rebooted the machine. still the same issue. thanks anyway!

@ ZanQdo and jawra

also sounds like a good suggestion, but the UI us so slow and unresponsive that this is virtually impossible.

@ andrew-101

another good idea that has actually been suggested to me (not in this thread). but I still have the same problem: the UI is so slow I can’t even navigate to the settings.

thank you all very much, but any other suggestions?

errr?? for what i see you are using the catalyst 7.x series and windows vista… Blame Dell, since they haven’t updated their drivers since, and AFAIK Blender uses OpenGL in a way really needs some updated drivers…

There’s no much you can do to make things works, probably the driver is buggy and i bet that Dell is not making any fix for the problem…

The actual catalyst 10.6 for mobility, aren’t supported for Dell, but you can try anyways… for what i see, if you really updated the driver, then vista is actively blocking it without telling you (sometimes i hate microsoft and their stupid policy about drivers). Your best bet is to try and contact Dell support, or try to contact AMD customer care… probably they can orient better than we can do.

There’s probably newer drivers available at dell.com

Edit: …

Well thanks for the suggestions everybody. I appreciate it.

I’ve tried most of what’s been suggested, but nothing’s worked so far. I’ve yet to call Dell/Microsoft and complain.

At this point I don’t have enough time to keep trying to figure this out (I actually just don’t have time for CG right now :[ ) so I’m just gonna let it go for now and then start back up when things get less hectic. At that point I’ll revive this thread if I still have issues (I might just have me a new gizmo by then…)

Anywho, thanks again!

-blue ;]

You’ll get it going eventually bluetiger. Hang in there!

thnx dude! i’ll prolly jus go back to 2.49b until i get a new computer (that is, when i find time for CG again… :stuck_out_tongue: )

try from the command line ./blender -noaudio

or ./blender -setaudio NULL

Blender won’t let me type into the command line. Thanks fer the suggestion though :smiley:

:rolleyes: He means start blender from the command prompt rather than starting it by clicking on an icon.

Ok, wow. Now I feel stupid :o (can you tell computers are not my forte?)

So I have now tried it the right way (sortof) and it didn’t work. It prolly didn’t work just cuz I did it wrong. I’ll have to figure this out later. no time now :smiley:

But yeah, thanks fer clearing that up fer me mr B8 :smiley:

If the sound it is the problem you can create a new blender.exe shortcut on descktop go to proprieties of the shorcut and edit the part “blender.exe” -noaudio

Woudn’t it be easier to upgrade your OS? Many horrible things have been written all around about Vista.

So I tried the shortcut thing and I couldn’t get it to work. Maybe I’m just doing it wrong…anyway, I think it’s a graphics card issue. As to upgrading the OS, maybe that would help (maybe, Vista isn’t really as bad as everyone says), but that’s not free :smiley:

So I gave up and switched back to 2.49b. I am now happily blending again. I think I’ll just wait till I can afford a new computer to start using 2.5.

Thanks fer all the suggestions!

-blue ;]