2.5 -- glass material problem

Rendering Settings:

Help. :slight_smile:

What appears to be wrong? It looks quite good!:wink:

Edit: Ah. The glass is opaque…

Sorry. I know nothing about yafaray :o

Nice character, though!

Make sure your head’s material is set to receive transparent shadows (under material --> shadows). It looks like it’s not getting any of the light shining through the helmet bowl because of this.

I am using blender internal.

Receiving transparent shadows didn’t solve it.

Is ambient occlusion on?

Ambient Occlusion is on.

This is issue is still not solved and I have tried a few things. If someone could post the correct material settings for this to work, that would be great.

Post a blend? Feel free to edit it down to just the head, helmet and light to keep it small. Otherwise we’re just guessing at possibilities.

This is a link to the file.

Your using ray-traced ambient occlusion. With that you HAVE to set the attenuation value small enough to deal with the head that is so close to the glass. Try 1 -it’s currently 10

Sorry I didn’t see your reply earlier.

I dont see attenuation anywhere. Thank you btw.

World settings -> Gather panel -> Attenuation.

You could also try unchecking the Cast Approximate box under Shadow in the head’s material properties, depending on how badly you want the AO on it. The main problem is that AO doesn’t handle transparency very well and seems to be based mainly on geometry.

Another thing I’m noticing is that your character’s head looks like it’s embedded inside of a solid glass sphere. If that’s what you’re going for, that’s ok, but it might look a little better if you use the Solidify modifier on the helmet to hollow it out.