2.5 still seeing hidden edges in edit mode wireframe

In any of the 2.5 versions or revisions I’ve used, when I hide a selection of vertices, I can still see the edges from them when I go into a wireframe edit mode. This can get very distracting, of course. I looked in the themes section of the user preferences to see if I could change the alpha value, but to no avail.
Anybody who has the answer deserves a cookie. :smiley:

In edit mode, look at Mesh Display Panel in View Properties(N) .
You can deselect Edges and Faces in Overlays options.

I’m running into the same issue and that solution doesn’t seem to work for me. Any other hints?

If you’re using the SubSurf modifier you’re seeing the mesh result of that one greyed out. You could disable it for edit mode only, so you won’t see the hidden vertices in edit mode.

Now I get it. But it only behaves like that when you also have an Armature modifier right?