2.53 Crashes on Startup

Well, this is quite unusual. I have the zip file of the beta, try to run it, but at the moment that it is try to open it, it crashes. I am not sure what is going on. All I did was run “blender.exe”, the command window opens, but it crashes. What is going on?

Note: My PC can run 2.52 well, and I did have 2.48 in my PC. I usually do not want to replace the newer Blender until I know it is VERY stable. My PC runs on Windows XP Media Center Version 2002, Service Pack 2, Intel Pentium 4 HyperThreading, 504 MB of RAM. I am not sure what the GPU is.

Thank you if anyone can figure out this usually problem. 2.52 is great and all, but I need to move forward. If 2.6 will fix all of the problems, than I guess I can wait.

Error messages ?, clues ?

No. There’s nothing. It’s just the command window, and then there’s a message informing me that it crashes and must close it.

As you know, I’m using the .ZIP version of 2.53. I did tried to use the self-installation version and install. Still, it does the same thing: open blender.exe and crashes. I am sorry if this is all unusual. I wish I can help, but this is all I can tell you all.

Exactly the same problem here on XP 32 Professional. Blank console … wait 5 seconds … crashes. Installer and ZIP of the 32 bit version.

Edit: doesn’t seem to be Python related, as it works on a different PC which also doesn’t have Python installed

Now that I think about it, I never checked 2.53 on my laptop. It’s a Vista with a AMD dual core, 2 Gigs of RAM, and a Nvidia graphics card. I bet it will run it just fine.

Someone needs to report on why 2.53 won’t open on XP when it should. Can anyone help on that?

Just a note - I’m running 2.53 beta on an intel core duo with win xp home edition sp3 without a problem. What version of 2.52 did you use? A recent build?

Randy

Recent build? The number is 27226?

Plus, your specs are a bit higher, and I don’t really have enough money to purchase a new processor . . . or even know how to install one. Still, if you think the recent build number has anything to do about it, that’s fine.

By the way, I can run it on my said laptop. I wonder why . . . besides better specs. -_-

EDIT: SVN DEV Builds work for me, so work-around achieved. would like to use official release though with all implemented bells-n-whistles. (Leaving the following for posterity and possible troubleshooting for others)

Hi all, new here. Please bear with me.

I am having same 2.53r3 beta (official site download: both ZIP and EXE) crash problem on my laptop, and am hoping one of you gurus can help. Sorry in advanced for long post, but I know details help to solve problems. I did extensive testing and research for hours before ever deciding to post here. I hope I have covered enough for those who know can digest, and offer a viable solution.

This is the first Blender installation I have ever installed (since 1.x days) crash on me. I regularly use 2.49b with Python 2.6.2 installed utilizing LuxBlend with no problems/crashes. I have 2.5 alpha 0 installed as well, and it opens fine, although I haven’t used it because I was waiting for a stable beta to be released. 2.5 alpha 0 will crash on me if I try to open the User Preferences (tested today) with the Windows crash box stating crash was in “sisgl.dll”. My on-board graphics is SIS with only OpenGL 1.2 (not upgradable).

SPECS & OUTLINE:

MS Windows XP Pro/Tablet Ed 2005 SP2 (can’t upgrade to 3, breaks important usage on my machine), AMD Athlon XP-M 2200+ at around 1.2 Ghz, 1024 MB RAM (Max upgrade), SIS 741 on-board graphics with OpenGL 1.2, Direct X 9c (last build available).

I have both MS Redistributable binary packages 2005 & 2008 installed, and even reinstalled latest version to no avail. Also, uninstalled Python 2.6.2, and installed 3.1.2 in hopes that would correct problem. Nope. Now my 2.49b LuxBlend is broken (Yay).

USAGE:

Open blender.exe, the console box opens up, and then a blank grey application window. Then the MS Windows crash box shows up and says Blender has crashed and needs to close. The console window says something like “found python folder 2.53” or such and then next line with blank cursor. Nothing further.

The MS Windows crash box says crash is in “ntdll.dll” in my System 32 folder, and I even replaced that dll to no avail. Crashes every open exactly the same.

TESTING:

I downloaded and installed 2 different build versions from the Dev build repository:

  1. Blender 2.53 - SVN 30870 Win32 by DingTo (Release Date: 07/29/10). It opened. I can see splash screen and click through tabs and parameters, but the left mouse button does not work for viewport manipulation. No rotate, scroll, or zoom available. Can select parameters with left mouse button fine, and can select objects with right mouse button fine. Also, program crashes if I try to select User Preferences with same “sisgl.dll” crash as above. This persons build works somewhat, so there is definitely a problem with the official build that the official devs might have overlooked for what I speculate is the “Media” builds of Windows XP.

EDIT: Can enable view manipulations via User Preference tab as noted by another member on forums with same crash problem.

  1. Blender 2.52-win32-trunk-r28391-Optimized by Tesf (Release Date: 04/23/10). Does not work. Same opening crash about “ntdll.dll” This version is optimized for SSE2 which I clearly do not have (so maybe the issue for not working).

If anyone can help or offer any solution, it would be greatly appreciated. I have been dying to try the new sculpt mode, and have been waiting patiently all this time for the beta just to find out it doesn’t want to play nice with my system. Thank you all in advanced!

Ken

EDIT: To correct technical data, and state I can enable view manipulations via User Preference tab in dev builds. Also, downloaded a new build by loopduplicate version 2.53.1 r30876 non-optimized (Release Date: 07/29/10). Works great, and love the new sculpt mode.

SVN Dev builds work, so there is something definitely wrong with the official release.

Thank you for being specific about my similar problem, DaremoK3. This is unusual for Blender to happen. Someone needs to report this right away. Otherwise, this problem will continue to spread.

EDIT: I did tried out the trunk you mentioned, DeremoK3. I feel like an idiot because it works! If the newer build is any better than 2.52, then I’ll replace it. Interesting thing about the build: there is a action in Game Logic that allows to treat a object like a bullet. It’s great if you are making games with projectiles! No, it doesn’t have to be a shooting game. You can be creative and use it for your own benefit, like I have.

I am rather new to Blender and am also having problems getting version 2.53(beta) to start properly under Windows XP. Unlike some of the others herin I do not get any messages. When I attempt to start the program I see the python script window open, but see no text in the window at all. The application window then opens but with no widgets, menus, text, or anything else - just a blank gray window.

About a minute later the two windows disappear. No messages, just gone.

Running Vista on my laptop I can get the application to run, but the workstation is a better environment for working with this kind of software (assuming it would run).

Thoughts? Does Blender create an error log somewhere that I could investigate?

I can’t start it up too, I get a error saying that “Blender.exe is not a valid Win32 application” :frowning: I used the installer. My OS is Windows XP - SP3, if it matters.

EDIT: the zip works just fine,for some reason.Computers are weird.

Hey Skykam,

I have the same problem. My machine does exactly the same thing when I try to run 2.5.3 beta. I’m running Windows XP, Home Edition, on an HP Pavilion with a little over a gig of ram. I’ve tried uninstalling all previous versions of Python, and I don’t currently have any Python environment variables set. Hope somebody figures out what’s going on.

Hi y’all.
I bumped into the exact same problem during my first startup of Blender 2.53 on Win XP Pro. Tried both the zip version as well as the installer - with the same outcome.
For me the solution was: I had a bunch of conflicting Python related environment variables defined in my system environment and needed to rid my environment of them.
In order to check if the same applies to you, open a windoze command prompt and type ‘SET’ to see the environment variables you have defined in there. If you see f.ex. PYTHONPATH or have included some version of python in your PATH environment variable, Blender 2.53 startup may well fail. At least it did so for me.
So the solution for me was to rid my environment of all python related environment variables and then start blender from the install directory by simply running the blender.exe

Hey guys, finally figured out how to get mine working. I had to turn my hardware acceleration down to almost nothing. (right-click desktop -> properties -> settings -> advanced -> troubleshoot)

Hope that helps a few of you.