2.53 particles can't render metaballs

I seem to have a problem rendering and visualizing metaballs as an instanced object in the particle system of blender 2.53.

Help would be much appreciated, might be a bug.


What problem do you actually have?
Do they show up in the 3d view?
Do they show up in the render?
Can you be more specific as you can use metaballs as particle objects

No they don’t show up in the viewport or in the render.
Yes I do mean metaballs as particle objects.

I’m using build 30967 and metaball particles show up OK. Do you have problems with other objects as particles? Have you tried increasing size in the Physics tab?

Problem solved! Thank you Alan K, it was the size of the particles.

Actually, a similar problem has been bugging me. Instanced object only show up for me when the Display is set to “Rendered.” If the particle amount is too high, the 3D view has to render all the geo and it often crashes blender.

Can 2.53 render final instances, but only display “Points,” for example?

Hmm, I have this problem when I switch particle physics from “newtonian” to “fluid”. In that case the metaballs dissapear, no matter which size I set.

Refinement of the error: It seems to only happen when I add a plane and set it as a collision object. I sometimes does not work with newtonain physics, too.