2.57 exe conversion problem

Hi all, my game is arriving to the stage when I want my friends to test it, but I encountered some problems. When I use the ‘save as runtime’ add-on, I get this message:

Traceback (most recent call last):
File “C:\Users\Kinoko\AppData\Roaming\Blender Foundation\Blender\2.57\scripts
addons\game_engine_save_as_runtime.py”, line 192, in execute
self.copy_dlls)
File “C:\Users\Kinoko\AppData\Roaming\Blender Foundation\Blender\2.57\scripts
addons\game_engine_save_as_runtime.py”, line 93, in WriteRuntime
bpy.ops.wm.save_as_mainfile(filepath=blend_path, compress=False, copy=True)
File “C:\Users\Kinoko\AppData\Roaming\Blender Foundation\Blender\2.57\scripts
modules\bpy\ops.py”, line 179, in call
ret = op_call(self.idname_py(), None, kw)
RuntimeError: Error: Can’t open file C__Program_Files_Blender_Foundation_Blender
[email protected] for writing: Permission denied.

location:<unknown location>:-1

(Using Windows 7.)

When I try running it with blenderplayer, most of the objects do not appear at all, but they are there because they contribute to the phyisics. Anyone having similar problem, possibly solution?

Well, here’s mine ( Linux 64):
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can’t find encoding
Abandon
My solution:
Don’t use 2.57
Bye

@Mavro - That’s a known error using Windows 7 - I suppose it doesn’t grant permission to write or change files with Blender usually. To fix this, run Blender as Administrator.

I would personally recommend using 2.57, as the UI is better, and it is a little faster than 2.49 in the game engine. Anyway, that’s my own opinion.

Thanks everyone! Running as an administrator solved the problem of conversion, however running as an exe makes objects disappear, and I cannot figure out why. The objects are phisycally there (ie I can bump into them) but they are invisible. Some pictures:

https://lh6.googleusercontent.com/-RCO3SxRG_xk/Te0EkxRtTjI/AAAAAAAAAl4/beIiFJ4Tg6A/inside.jpg
This is how it should look, running inside Blender 2.57.

https://lh5.googleusercontent.com/-cikSeQP3uNM/Te0Ek7DQaJI/AAAAAAAAAl8/DPrk0DYrG_w/outside.jpg
This is how it looks the .exe file running.

All the sounds work though.

I think the problems are caused by having modifiers that aren’t applied. Try applying anything but armature modifiers, and seeing if that fixes the issues.

I am a quite simple soul, so I do not use modifiers very much, except for armatures. It is not even a material or texture problem because some objects with the same materials and textures appear and some other not. So I am out of ideas right now.

Edit: It works if I set the game to multitexture from GLSL, only looks terrible. Looks like one step closer.

Just to let you know, Blender doesn’t have permission to write to the program files, which is why you had to run as admin. If you save your runtime and blends somewhere else (say your Desktop), then you won’t have to run Blender as admin. As for the disappearing meshes, this is a known bug that will be fixed this summer.

Edit:
@OTO
You get this error when Python isn’t found. The Linux Blenderplayer currently has an issue finding Python in a lib folder next to it (what the copy Python option does). Try copying the 2.57 folder and put it alongside your runtime. Then it should be fine.

@Moguri: This answers my questions, I just have to be patient and keep up with the updates. (I could not find this bug listed/reported, sorry.) Thank you!

There are some listed here:
http://wiki.blender.org/index.php/User:Kupoman/GSOC_2011_TaskList#Modifier_Bugs

Moguri
thank you very much for the tip!
It works now!
I’ve been acting like a jerk recently, but it’s stronger than me: I don’t like 2.57!
Bye