[2.58]Shadows only material

Hi,

I’m trying to composite this animation, and I can’t get the shadows only material to work. The mountain is an avi, so it’s background, but I have a mesh that’s almost the same shape on it, so it can receive shadows. If I disable ‘traceable’ and use shadows only with alpha 1, it gives me a usable shadow on the surface as the camera moves over the mountain, but when the sphere is behind the mountain it gives me this.
It seems like it’s projecting the sphere unto the mountain’s shadow receiving material, as it sees the sphere as being in the background. This way those parts of the sphere that are behind the mountain get the same Z value as the shadows only mesh, so they get in front of the mountain.


On a sidenote, if I try to turn traceable back on, blender renders the whole mesh as a semi-transparent object with internal shading, like this despite shadows only being turned on. But this also gives a much more complete shadow of the sphere than without ‘traceable’:


I hate the shadows only setting, I don’t know why, but it never seems to work for me.

I would move the mountains mesh to another renderlayer and enable the shadows pass, then composite it back in.

This method also gives you more controll over the colour / intensity of the shower.

Good luck :smiley: