2.59: Background image aspect ratio

hi everyone. migrating from 2.49b to 2.59
the background images option has been moved. strange but whatever, i can deal with that.

However, my background images are now showing in what appears to be a 4:3 aspect ratio, regardless of the dimensions of the source. This is making a horrible mess of things. Any idea what’s going wrong? I’ve tried deleting it and reimporting a new one but no luck. there’s no option there for scaling it on axes either, only a flat scale of both at once.

An update on this issue. I’m finding that it seems to occur somewhat inconsistently. I’ve got a few images now working fine that are not in 4:3 ratio. I’ve also got one image which consistently refuses to display in it’s native ratio, until i messed around with packing and unpacking it a bit, now it seems to work.

One thing that’s ridiculously confusing is that there are two file selection boxes in the background image section, and I can’t figure out any difference in behaviour between the two.

I’m extremely unhappy with the changes to this feature so far, but i guess it’s mostly working now. I’d like some explanation if anyone can give advice though, so not marking solved yet.