2.6 --> 2.7 script migration.

The title says it all, I have a BGE script that works in 2.69 but nothing later. Is it possible to do something to the script that will make it work in newer versions?

You should show the errors / upload an example blend / script.

Hi! if you’re lucky, you could try to write:

import bge

at the top of the script :slight_smile:

It’s the vehicle wrapper scripts courtesy of Tutorialsforblender3d.org

http://tutorialsforblender3d.com/Game_Engine/Vehicle/Vehicle_2.html

They haven’t uploaded a version of the script for 2.7 or later yet(not sure if they will), But here’s the version im using (on 2.69)

CarSetup.py
http://pastebin.com/3fVipz8g
Powertrain.py
http://pastebin.com/BJLKCFZr
Suspension.py
http://pastebin.com/fQQTwvZp

blend
http://tutorialsforblender3d.com/Game_Engine/Vehicle/blend/Vehicle_Finished_26.blend

It runs in 2.7 but is buggy, and just crashes in 2.71(Even when i move import bge to the top or remove it on each script).