2.61 not opening .avi files

hello I am using blender 2.61.0 r42905. in Linux Ubuntu 11.10. in the previous version of blender 2.59 I am able to open . avi files in the video sequence editor. but now I try and blender gives me and error message (File “filename.avi” could not be opened). I am fairly certain its not ffmpeg compatibility issues within Linux because I can still open the .avi files in 2.59, as well as watch them in VLC media player. I’m sorry if this is long winded, I just want to give as much information as possible so we can skip all the easy trouble shooting.

any help or insight you could give would be greatly appreciated.

if you did build it on your own, you missed the dependencys to your current ffmpeg-libs -
if it is a built from someone else, chances are the built is not made for all those libs.
Last, the *.avi does not guarantee the used codec can be read, the *.avi is only a container for a lot of different codecs.

fixed it. I just downlaoded a new ffmpeg revision from graphicall.org and pasted it into my blender svn folder now it works